summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rw-r--r--abtransfers.desktop9
-rw-r--r--abtransfers.pro171
4 files changed, 245 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0ae95090527
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = abtransfers
+ pkgdesc = A program to perform HBCI-Transfers with aqbanking
+ pkgver = 0.0.5.0
+ pkgrel = 2
+ url = http://schmufu.dyndns.org/dokuwiki/ab_transfer:start
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ depends = aqbanking
+ source = http://schmufu.dyndns.org/abtransfers/source/abtransfers-0.0.5.0.tar.bz2
+ source = abtransfers.desktop
+ source = abtransfers.pro
+ md5sums = bc38d7ee81f1d0456872c384f2890cd8
+ md5sums = 5ef91bc33a3d58984a61e7143fe6f925
+ md5sums = bc9a5bcd3a3883b7bb299ccc17bc77c6
+ sha1sums = 90163670a917d8e2476151450f42863c0e56ed8d
+ sha1sums = d092c551475591fdb7d7801d1f09d193c1f85b31
+ sha1sums = 679aae779f1dbe932c62cdb7e2dd4bbde612ade3
+ sha512sums = b7c2ec6e6f41cf44bfea4e3a8e005a65f0632889a177f7ad51b75fce668606b3cca009ed8c55e9b55f7181617eded993626e5f580a2fc49928eedc5b974711e4
+ sha512sums = e873695b03c5d9a722a948c982dbd6a94bdd65099707e44f8bed231a85b342f7b5f900e44c42a9bd2cb1aebec23964917788722589e9a6ed6ba0a467b093d5a3
+ sha512sums = f8f22ecb620e35eb00b9c667779652fba5a48b3b8ed9d0eb03f74949f25aa3ece72c08e8b6de72224b97afecd55c250a9ef8731bc36c5202344743d1a7e7903b
+
+pkgname = abtransfers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d598bc48346c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: strubbisch <becker.frank.77@googlemail.com>
+# Contributor: Frank Becker <becker.frank.77@googlemail.com>
+pkgname=abtransfers
+pkgver=0.0.5.0
+pkgrel=2
+pkgdesc="A program to perform HBCI-Transfers with aqbanking"
+arch=(i686 x86_64)
+url="http://schmufu.dyndns.org/dokuwiki/ab_transfer:start"
+license=('GPL')
+depends=('qt4' 'aqbanking')
+source=(http://schmufu.dyndns.org/abtransfers/source/$pkgname-$pkgver.tar.bz2
+ $pkgname.desktop
+ abtransfers.pro)
+
+build() {
+ cp abtransfers.pro $srcdir/$pkgname-$pkgver
+ cd $srcdir/$pkgname-$pkgver
+ qmake-qt4
+ make
+}
+package() {
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/$pkgname/icon
+ mkdir -p $pkgdir/usr/share/applications
+ cd $srcdir/$pkgname-$pkgver/build
+ install -m755 abtransfers $pkgdir/usr/bin/
+ cd $srcdir/$pkgname-$pkgver/images
+ install -m644 bank_transfer_128x128.png $pkgdir/usr/share/$pkgname/icon/icon.png
+ cd $srcdir
+ install -m644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+}
+md5sums=('bc38d7ee81f1d0456872c384f2890cd8'
+ '5ef91bc33a3d58984a61e7143fe6f925'
+ 'bc9a5bcd3a3883b7bb299ccc17bc77c6')
+sha1sums=('90163670a917d8e2476151450f42863c0e56ed8d'
+ 'd092c551475591fdb7d7801d1f09d193c1f85b31'
+ '679aae779f1dbe932c62cdb7e2dd4bbde612ade3')
+sha512sums=('b7c2ec6e6f41cf44bfea4e3a8e005a65f0632889a177f7ad51b75fce668606b3cca009ed8c55e9b55f7181617eded993626e5f580a2fc49928eedc5b974711e4'
+ 'e873695b03c5d9a722a948c982dbd6a94bdd65099707e44f8bed231a85b342f7b5f900e44c42a9bd2cb1aebec23964917788722589e9a6ed6ba0a467b093d5a3'
+ 'f8f22ecb620e35eb00b9c667779652fba5a48b3b8ed9d0eb03f74949f25aa3ece72c08e8b6de72224b97afecd55c250a9ef8731bc36c5202344743d1a7e7903b')
diff --git a/abtransfers.desktop b/abtransfers.desktop
new file mode 100644
index 000000000000..34c6101ff6f0
--- /dev/null
+++ b/abtransfers.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=AB-Transfers
+Exec=abtransfers
+Type=Application
+GenericName=Online-Banking-Programm
+Terminal=false
+Icon=/usr/share/abtransfers/icon/icon.png
+X-KDE-StartupNotify=false
+Categories=Application;Office;
diff --git a/abtransfers.pro b/abtransfers.pro
new file mode 100644
index 000000000000..34d7946cc1bf
--- /dev/null
+++ b/abtransfers.pro
@@ -0,0 +1,171 @@
+# -------------------------------------------------
+# Project created by QtCreator 2011-07-03T18:32:54
+# -------------------------------------------------
+VERSION = 0.0.5.0
+!macx:TARGET = abtransfers
+macx:TARGET = "AB-Transfers"
+DESTDIR = build
+TEMPLATE = app
+
+USEWEBKIT=$$system(pkg-config QtWebKit && echo "available")
+contains(USEWEBKIT, "available") {
+ message("QtWebKit available")
+ QT += webkit
+ DEFINES += USE_QT_WEBKIT
+} else {
+ message("QtWebKit not available, using QLabel")
+}
+
+TRANSLATIONS = $$files(translation/abtransfers.*.ts)
+
+SOURCES += src/main.cpp \
+ src/mainwindow.cpp \
+ src/widgets/bankaccountswidget.cpp \
+ src/aqb_accountinfo.cpp \
+ src/aqb_accounts.cpp \
+ src/aqb_banking.cpp \
+ src/widgets/debugdialogwidget.cpp \
+ src/widgets/knownempfaengerwidget.cpp \
+ src/abt_empfaengerinfo.cpp \
+ src/abt_settings.cpp \
+ src/abt_transaction_base.cpp \
+ src/abt_transactions.cpp \
+ src/abt_job_ctrl.cpp \
+ src/pages/page_log.cpp \
+ src/pages/page_ausgang.cpp \
+ src/abt_conv.cpp \
+ src/abt_validators.cpp \
+ src/abt_transactionlimits.cpp \
+ src/widgets/widgetlineeditwithlabel.cpp \
+ src/pages/pagewidgettests.cpp \
+ src/widgets/widgetaccountdata.cpp \
+ src/widgets/widgettextkey.cpp \
+ src/widgets/widgetpurpose.cpp \
+ src/widgets/widgetvalue.cpp \
+ src/widgets/widgetdate.cpp \
+ src/widgets/widgetrecurrence.cpp \
+ src/widgets/widgettransfer.cpp \
+ src/widgets/widgetknownstandingorders.cpp \
+ src/widgets/widgetaccountcombobox.cpp \
+ src/widgets/widgetknowndatedtransfers.cpp \
+ src/abt_jobinfo.cpp \
+ src/abt_parser.cpp \
+ src/abt_standingorderinfo.cpp \
+ src/abt_datedtransferinfo.cpp \
+ src/abt_history.cpp \
+ src/dialogs/dialogsettings.cpp \
+ src/dialogs/abt_dialog.cpp \
+ src/pages/page_history.cpp \
+ src/aqb_imexporters.cpp \
+ src/translationchooser.cpp \
+ src/widgets/widgetcalculator.cpp
+HEADERS += src/mainwindow.h \
+ src/widgets/bankaccountswidget.h \
+ src/aqb_accountinfo.h \
+ src/aqb_accounts.h \
+ src/aqb_banking.h \
+ src/globalvars.h \
+ src/widgets/debugdialogwidget.h \
+ src/widgets/knownempfaengerwidget.h \
+ src/abt_empfaengerinfo.h \
+ src/abt_settings.h \
+ src/abt_transaction_base.h \
+ src/abt_transactions.h \
+ src/abt_job_ctrl.h \
+ src/pages/page_log.h \
+ src/pages/page_ausgang.h \
+ src/abt_conv.h \
+ src/abt_validators.h \
+ src/abt_transactionlimits.h \
+ src/widgets/widgetlineeditwithlabel.h \
+ src/pages/pagewidgettests.h \
+ src/widgets/widgetaccountdata.h \
+ src/widgets/widgettextkey.h \
+ src/widgets/widgetpurpose.h \
+ src/widgets/widgetvalue.h \
+ src/widgets/widgetdate.h \
+ src/widgets/widgetrecurrence.h \
+ src/widgets/widgettransfer.h \
+ src/widgets/widgetknownstandingorders.h \
+ src/widgets/widgetaccountcombobox.h \
+ src/widgets/widgetknowndatedtransfers.h \
+ src/abt_jobinfo.h \
+ src/abt_parser.h \
+ src/abt_standingorderinfo.h \
+ src/abt_datedtransferinfo.h \
+ src/abt_history.h \
+ src/dialogs/dialogsettings.h \
+ src/dialogs/abt_dialog.h \
+ src/pages/page_history.h \
+ src/aqb_imexporters.h \
+ src/translationchooser.h \
+ src/widgets/widgetcalculator.h
+FORMS += src/mainwindow.ui \
+ src/widgets/bankaccountswidget.ui \
+ src/widgets/debugdialogwidget.ui \
+ src/widgets/knownempfaengerwidget.ui \
+ src/pages/page_log.ui \
+ src/pages/page_ausgang.ui \
+ src/dialogs/dialogsettings.ui \
+ src/dialogs/abt_dialog.ui \
+ src/pages/page_history.ui
+OTHER_FILES += \
+ documentation/Doxyfile \
+ documentation/HBCI_Geschaeftsvorfaelle.txt \
+ translation/abtransfers-helptext_de.html \
+ translation/abtransfers-helptext_en.html \
+ translation/abtransfers.en_GB.ts \
+ translation/README.translations
+RESOURCES += src/resources.qrc
+
+unix|macx {
+ CONFIG += link_pkgconfig
+ PKGCONFIG += gwenhywfar gwengui-qt4 aqbanking
+} else {
+ warning(configuring project for a not tested platform. The LIBS are probably wrong.)
+ #The above (CONFIG/PKGCONFIG) could be used if pkg-config is available.
+ #Otherwise adjust the following
+ LIBS += -laqbanking -lgwenhywfar -lgwengui-qt4
+ INCLUDEPATH += /usr/include/aqbanking5 \
+ /usr/include/gwenhywfar4
+}
+
+# This is needed for the dock icon on Max OS X.
+macx:ICON = images/abtransfers.icns
+# According to http://osdir.com/ml/kde-commits/2011-09/msg06346.html the following seems to be necessary.
+macx:DEFINES += MSG_NOSIGNAL=0
+
+# This variable specifies the directory where all intermediate moc files should be placed.
+MOC_DIR = tmp
+
+# This variable specifies the directory where all intermediate objects should be placed.
+OBJECTS_DIR = tmp
+UI_DIR = tmp
+
+# Compile translations, so that they are useable for the resources file
+# But keep in mind that
+# 1) "lupdate's CODECFORTR is deprecated and will be removed soon." (Seems to be only needed for Windows!)
+# 2) "QTextCodec::codecForTr() and QTextCodec::setCodecForTr() have been removed" -->> main.cpp affected!!!
+# (See http://qt.gitorious.org/qt/qtbase/blobs/stable/dist/changes-5.0.0 for reference.)
+!greaterThan(QT_MAJOR_VERSION, 4):CODECFORTR = UTF-8
+system(lrelease-qt4 $${TRANSLATIONS})
+
+# Only one of the two commands will return a valid SVN revision, depending on whether the working is SVN or Hg(+hgsubversion):
+SVN_REVISION = 617
+HG_REVISION = ""
+
+# revision as define for the Preprocessor ( \\\" so that \" goes to the Preprocessor)
+# DEFINES += MVW_SVN_REVISION=\\\"$${SVN_REVISION}\\\" \
+# MVW_VERSION=\\\"$${VERSION}\\\" \ # MVW_VERSION_EXTRA=\"\\\"'development-version-test test-test'\\\"\" #damit auch space möglich ist
+# MVW_VERSION_EXTRA=\\\"development-version\\\" # keine space möglich!
+DEFINES += ABTRANSFER_SVN_REVISION=\\\"$${SVN_REVISION}$${HG_REVISION}\\\" \
+ ABTRANSFER_VERSION=\\\"$${VERSION}\\\"
+
+
+# NO_DEBUG
+# QT_NO_DEBUG \
+# QT_NO_DEBUG_STREAM
+# we want to stop the build and output some information (only for debug)
+# error(Subversion revision: $$SVN_REVISION)
+message(Subversion revision: $${SVN_REVISION}$${HG_REVISION})
+#message(Mercurial revision: $${HG_REVISION})