summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b50b4394216
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = acme
+ pkgdesc = A free crossassembler, that can produce code for the 6502, 65c02 and 65816 processors.
+ pkgver = 091
+ pkgrel = 2
+ url = http://www.esw-heim.tu-clausthal.de/~marco/smorbrod/acme
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://www.esw-heim.tu-clausthal.de/~marco/smorbrod/acme/current/acme091src.tar.bz2
+ md5sums = 5f7af22cc82307b8e9b29a0314a01b76
+
+pkgname = acme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b91ee57f09a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sebastian Wolf <fatmike303 at googlemail dot com>
+pkgname=acme
+pkgver=091
+pkgrel=2
+pkgdesc="A free crossassembler, that can produce code for the 6502, 65c02 and 65816 processors."
+arch=('i686' 'x86_64')
+url="http://www.esw-heim.tu-clausthal.de/~marco/smorbrod/acme"
+license=('GPL')
+source=(http://www.esw-heim.tu-clausthal.de/~marco/smorbrod/${pkgname}/current/${pkgname}${pkgver}src.tar.bz2)
+md5sums=('5f7af22cc82307b8e9b29a0314a01b76')
+depends=('glibc')
+
+build() {
+ cd "${srcdir}/${pkgname}${pkgver}/src"
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}${pkgver}/src"
+ install -D -m755 acme ${pkgdir}/usr/bin/acme
+}