summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2841ee3e0953..7ae62efab858 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = acousticbrainz-client-git
+pkgbase = acousticbrainz-client
pkgdesc = client to upload data to an acousticbrainz server
- pkgver = 0.1.r2.g366bdd1
+ pkgver = 0.1
pkgrel = 1
url = http://acousticbrainz.org/
arch = any
@@ -8,8 +8,9 @@ pkgbase = acousticbrainz-client-git
makedepends = git
depends = essentia-acousticbrainz
depends = python-requests
- source = git+https://github.com/MTG/acousticbrainz-client.git
- md5sums = SKIP
+ conflicts = acousticbrainz-client-git
+ source = https://github.com/MTG/acousticbrainz-client/archive/0.1.tar.gz
+ sha256sums = cc5b40591ecf54fb5f3c185fc0e9f350a6a29e9e38ba81a0175641e2e570caba
-pkgname = acousticbrainz-client-git
+pkgname = acousticbrainz-client
diff --git a/PKGBUILD b/PKGBUILD
index 3e10626efead..96dd40bdf029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
-pkgname=acousticbrainz-client-git
-_pkgname=acousticbrainz-client
+pkgname=acousticbrainz-client
_python=python
-pkgver=0.1.r2.g366bdd1
+pkgver=0.1
pkgrel=1
pkgdesc="client to upload data to an acousticbrainz server"
arch=('any')
@@ -10,31 +9,23 @@ url="http://acousticbrainz.org/"
license=('GPL3')
depends=('essentia-acousticbrainz' 'python-requests')
makedepends=('git')
-provides=()
-conflicts=()
-replaces=()
-options=()
-source=("git+https://github.com/MTG/$_pkgname.git")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
+conflicts=('acousticbrainz-client-git')
+source=("https://github.com/MTG/$pkgname/archive/${pkgver}.tar.gz")
+sha256sums=('cc5b40591ecf54fb5f3c185fc0e9f350a6a29e9e38ba81a0175641e2e570caba')
prepare() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
# we have that in essentia-acousticbrainz
sed -i -e "/streaming_extractor_music/d" setup.py
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
$_python setup.py build
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
$_python setup.py install --root="$pkgdir/" --optimize=1
}