summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12935c353e54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Sep 28 21:05:32 UTC 2017
+pkgbase = activinspire-sk
+ pkgdesc = Presentation Software to use with Promethean Hardware products - SK language pack
+ pkgver = 2.10.66827
+ pkgrel = 1
+ url = https://support.prometheanworld.com/product/activinspire
+ arch = any
+ license = unknown
+ depends = activinspire
+ noextract = activinspire-help-sk_1.0.2-14_all.deb
+ noextract = activresources-core-sk_1.0.1-147_all.deb
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire-help-sk/activinspire-help-sk_1.0.2-14_all.deb
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activresources-core-sk/activresources-core-sk_1.0.1-147_all.deb
+ md5sums = cd9eb604c00d26db50c09678ef4559e2
+ md5sums = d19deb72eb1b13d4ece18ee5d126e064
+
+pkgname = activinspire-sk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52c0794a8ecb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Bazon <bazonbloch@arcor.de>
+pkgname=activinspire-sk
+pkgver=2.10.66827
+pkgrel=1
+pkgdesc="Presentation Software to use with Promethean Hardware products - SK language pack"
+arch=('any')
+url="https://support.prometheanworld.com/product/activinspire"
+license=('unknown')
+depends=('activinspire')
+
+lang=${pkgname/activinspire-/}
+_u="http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/"
+source=()
+
+source+=(
+ ${_u}activinspire-help-${lang}/activinspire-help-${lang}_1.0.2-14_all.deb
+ ${_u}activresources-core-${lang}/activresources-core-${lang}_1.0.1-147_all.deb
+ )
+
+noextract=("${source[@]##*/}")
+
+prepare() {
+ cd $srcdir
+
+ [ ! -d core.${lang} ] && mkdir core.${lang}
+ bsdtar -C core.${lang} -xf activresources-core-${lang}_1.0.1-147_all.deb
+ bsdtar -C core.${lang} -xf core.${lang}/data.tar.gz
+
+ [ ! -d help.${lang} ] && mkdir help.${lang}
+ bsdtar -C help.${lang} -xf activinspire-help-${lang}_1.0.2-14_all.deb
+ bsdtar -C help.${lang} -xf help.${lang}/data.tar.gz
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mv $srcdir/core.${lang}/var ${pkgdir}/var
+ mv $srcdir/help.${lang}/usr/local/bin ${pkgdir}/usr
+
+}
+md5sums=('cd9eb604c00d26db50c09678ef4559e2'
+ 'd19deb72eb1b13d4ece18ee5d126e064')