summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
3 files changed, 54 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..165be532d112
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = ad3
+ pkgdesc = Alternating directions dual decomposition approximate MAP decoder
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = http://www.ark.cs.cmu.edu/AD3/
+ arch = x86_64
+ license = LGPL
+ depends = eigen
+ source = http://www.cs.cmu.edu/~afm/AD3/AD3-2.0.2.tar.gz
+ options = staticlibs
+ options = !makeflags
+
+pkgname = ad3
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..161df1725534
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ad3
+ pkgdesc = Alternating directions dual decomposition approximate MAP decoder
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = http://www.ark.cs.cmu.edu/AD3/
+ arch = x86_64
+ license = LGPL
+ depends = eigen
+ options = staticlibs
+ options = !makeflags
+ source = http://www.cs.cmu.edu/~afm/AD3/AD3-2.0.2.tar.gz
+ md5sums = 57d54349b00888f44a7fd0a3296a2d12
+
+pkgname = ad3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44c7deec8d2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Benoit Favre <benoit.favre@lif.univ-mrs.fr>
+pkgname=ad3
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Alternating directions dual decomposition approximate MAP decoder"
+arch=(x86_64)
+url="http://www.ark.cs.cmu.edu/AD3/"
+license=('LGPL')
+depends=(eigen)
+makedepends=()
+options=(staticlibs !makeflags)
+source=(http://www.cs.cmu.edu/~afm/AD3/AD3-${pkgver}.tar.gz)
+md5sums=(57d54349b00888f44a7fd0a3296a2d12)
+
+build() {
+ cd "$srcdir/AD3-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/AD3-$pkgver"
+ install -v -Dm755 ad3_multi "$pkgdir/usr/bin/ad3_multi"
+ install -v -Dm644 -t "$pkgdir/usr/lib/" ad3/libad3.a
+ install -v -Dm644 -t "$pkgdir/usr/include/ad3" ad3/*.h
+}