summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD45
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85243389f6a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = advene
+ pkgdesc = Video annotation and hypervideo authoring
+ pkgver = 3.13.1
+ pkgrel = 1
+ url = https://github.com/oaubert/advene
+ arch = any
+ license = GPL2
+ depends = frei0r-plugins
+ depends = gst-editing-services
+ depends = gst-libav
+ depends = gst-plugin-opencv
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-python
+ depends = gtksourceview3
+ depends = librsvg
+ depends = pulseaudio
+ depends = python-cairo
+ depends = python-cherrypy
+ depends = python-nltk
+ depends = python-opencv
+ depends = python-objgraph
+ depends = python-pillow
+ depends = python-rdflib
+ depends = python-regex
+ depends = python-requests
+ depends = python-scipy
+ depends = python-setuptools
+ depends = python-simplejson
+ depends = webkit2gtk
+ optdepends = espeak: TTS support
+ optdepends = festival: TTS support
+ optdepends = alsa-utils: TTS support - with festival
+ optdepends = brltty: Braille support
+ optdepends = pocketsphinx: Speech recognition
+ provides = python-simpletal=5.2
+ conflicts = python-simpletal=5.2
+ source = advene-3.13.1.tar.gz::https://github.com/oaubert/advene/archive/refs/tags/release/3.13.1.tar.gz
+ sha256sums = fbe98802f1c6dce44b554177855ef354bc4fa04d258486ee8b2aedeb8086d829
+
+pkgname = advene
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9b118b8dbd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: staphon7 <staphon7 at orange dot fr>
+pkgname="advene"
+pkgver=3.13.1
+pkgrel=1
+pkgdesc="Video annotation and hypervideo authoring"
+arch=('any')
+url="https://github.com/oaubert/advene"
+license=('GPL2')
+depends=('frei0r-plugins'
+ 'gst-editing-services'
+ 'gst-libav'
+ 'gst-plugin-opencv'
+ 'gst-plugins-bad'
+ 'gst-plugins-ugly'
+ 'gst-python'
+ 'gtksourceview3'
+ 'librsvg'
+ 'pulseaudio'
+ 'python-cairo'
+ 'python-cherrypy'
+ 'python-nltk'
+ 'python-opencv'
+ 'python-objgraph'
+ 'python-pillow'
+ 'python-rdflib'
+ 'python-regex'
+ 'python-requests'
+ 'python-scipy'
+ 'python-setuptools'
+ 'python-simplejson'
+ 'webkit2gtk')
+optdepends=('espeak: TTS support'
+ 'festival: TTS support'
+ 'alsa-utils: TTS support - with festival'
+ 'brltty: Braille support'
+ 'pocketsphinx: Speech recognition')
+provides=('python-simpletal=5.2')
+conflicts=('python-simpletal=5.2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/oaubert/advene/archive/refs/tags/release/${pkgver}.tar.gz")
+sha256sums=('fbe98802f1c6dce44b554177855ef354bc4fa04d258486ee8b2aedeb8086d829')
+
+package() {
+ cd "$pkgname-release-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}