summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-for-boost-1.81.0.patch56
-rw-r--r--PKGBUILD9
3 files changed, 67 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a058fa00ec6..58f079245bc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegisub-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support
pkgver = 3.2.2.r407.6f546951b
- pkgrel = 3
+ pkgrel = 4
url = http://www.aegisub.org
arch = x86_64
license = GPL
@@ -31,11 +31,13 @@ pkgbase = aegisub-git
source = git+https://github.com/Aegisub/assdraw.git
source = 0001-Use-target-name-without-directory-in-_OBJ-macro.patch
source = 0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
+ source = 0001-Fix-for-boost-1.81.0.patch
source = Remove-second-argument-to-StartStyling.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ce90cd9a9c56abcbafeb88d33280d53bee5af98cd9e15f50d6a9e49ae1edda30
sha256sums = c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17
+ sha256sums = 0ae8ffafa9819b4cb49ef5e399cab549129da637058a54368519ed0603c1b24f
sha256sums = 42d2c03d19eb6d64b0eb26c6c591fc142f61fcc251b0efcb91377f40448d9778
pkgname = aegisub-git
diff --git a/0001-Fix-for-boost-1.81.0.patch b/0001-Fix-for-boost-1.81.0.patch
new file mode 100644
index 000000000000..ac264bc70676
--- /dev/null
+++ b/0001-Fix-for-boost-1.81.0.patch
@@ -0,0 +1,56 @@
+diff --git a/libaegisub/include/libaegisub/lua/utils.h b/libaegisub/include/libaegisub/lua/utils.h
+index c5a65d6e4..f4921d582 100644
+--- a/libaegisub/include/libaegisub/lua/utils.h
++++ b/libaegisub/include/libaegisub/lua/utils.h
+@@ -87,7 +87,10 @@ int exception_wrapper(lua_State *L) {
+
+ template<typename T>
+ void set_field(lua_State *L, const char *name, T value) {
+- push_value(L, value);
++ if constexpr(std::is_convertible<T, std::string>::value)
++ push_value(L, static_cast<std::string>(value));
++ else
++ push_value(L, value);
+ lua_setfield(L, -2, name);
+ }
+
+diff --git a/src/auto4_lua.cpp b/src/auto4_lua.cpp
+index 245689679..6d479b2c3 100644
+--- a/src/auto4_lua.cpp
++++ b/src/auto4_lua.cpp
+@@ -115,7 +115,8 @@ namespace {
+ int get_translation(lua_State *L)
+ {
+ wxString str(check_wxstring(L, 1));
+- push_value(L, _(str).utf8_str());
++ const char* val = static_cast<const char*>( _(str).utf8_str());
++ push_value(L, val);
+ return 1;
+ }
+
+diff --git a/src/command/video.cpp b/src/command/video.cpp
+index fb2bcb0ba..77e3e9ca7 100644
+--- a/src/command/video.cpp
++++ b/src/command/video.cpp
+@@ -475,7 +475,7 @@ static void save_snapshot(agi::Context *c, bool raw) {
+ // If where ever that is isn't defined, we can't save there
+ if ((basepath == "\\") || (basepath == "/")) {
+ // So save to the current user's home dir instead
+- basepath = wxGetHomeDir().c_str();
++ basepath = static_cast<const char*>(wxGetHomeDir().c_str());
+ }
+ }
+ // Actual fixed (possibly relative) path, decode it
+diff --git a/src/dialog_attachments.cpp b/src/dialog_attachments.cpp
+index 38ff53027..e30339f81 100644
+--- a/src/dialog_attachments.cpp
++++ b/src/dialog_attachments.cpp
+@@ -161,7 +161,7 @@ void DialogAttachments::OnExtract(wxCommandEvent &) {
+
+ // Multiple or single?
+ if (listView->GetNextSelected(i) != -1)
+- path = wxDirSelector(_("Select the path to save the files to:"), to_wx(OPT_GET("Path/Fonts Collector Destination")->GetString())).c_str();
++ path = static_cast<const char*>(wxDirSelector(_("Select the path to save the files to:"), to_wx(OPT_GET("Path/Fonts Collector Destination")->GetString())).c_str());
+ else {
+ path = SaveFileSelector(
+ _("Select the path to save the file to:"),
diff --git a/PKGBUILD b/PKGBUILD
index d2616fb37603..bab2aea7b086 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
+# Maintainer: arch1t3cht <arch1t3cht@gmail.com>
# Maintainer: Qirui Wang <wqr.prg@gmail.com>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=aegisub-git
pkgver=3.2.2.r407.6f546951b
-pkgrel=3
+pkgrel=4
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=(x86_64)
url=http://www.aegisub.org
@@ -43,12 +44,15 @@ source=(
0001-Use-target-name-without-directory-in-_OBJ-macro.patch
# https://github.com/Aegisub/Aegisub/commit/5f235ff459e6a7ec36639894d1f45a638a9d73f3.patch
0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
+ # https://gitlab.archlinux.org/archlinux/packaging/packages/aegisub/-/blob/12e1e5ee64afb7cfb5a43a998774642bc1eeede6/boost-1.81.0.patch
+ 0001-Fix-for-boost-1.81.0.patch
Remove-second-argument-to-StartStyling.patch
)
sha256sums=('SKIP'
'SKIP'
'ce90cd9a9c56abcbafeb88d33280d53bee5af98cd9e15f50d6a9e49ae1edda30'
'c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17'
+ '0ae8ffafa9819b4cb49ef5e399cab549129da637058a54368519ed0603c1b24f'
'42d2c03d19eb6d64b0eb26c6c591fc142f61fcc251b0efcb91377f40448d9778')
pkgver() {
@@ -73,6 +77,9 @@ prepare() {
# Fix build with wxWidgets 3.0
patch -p1 -i ../0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
+ # Fix build with boost 1.81.0
+ patch -p1 -i ../0001-Fix-for-boost-1.81.0.patch
+
# Fix runtime warning "The second argument passed to StartStyling should be 0"
patch -p1 -i ../Remove-second-argument-to-StartStyling.patch