summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--Remove-second-argument-to-StartStyling.patch48
3 files changed, 58 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a8766b1fea4..7a058fa00ec6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegisub-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support
pkgver = 3.2.2.r407.6f546951b
- pkgrel = 2
+ pkgrel = 3
url = http://www.aegisub.org
arch = x86_64
license = GPL
@@ -31,9 +31,11 @@ pkgbase = aegisub-git
source = git+https://github.com/Aegisub/assdraw.git
source = 0001-Use-target-name-without-directory-in-_OBJ-macro.patch
source = 0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
+ source = Remove-second-argument-to-StartStyling.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ce90cd9a9c56abcbafeb88d33280d53bee5af98cd9e15f50d6a9e49ae1edda30
sha256sums = c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17
+ sha256sums = 42d2c03d19eb6d64b0eb26c6c591fc142f61fcc251b0efcb91377f40448d9778
pkgname = aegisub-git
diff --git a/PKGBUILD b/PKGBUILD
index b38b02f75512..d2616fb37603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aegisub-git
pkgver=3.2.2.r407.6f546951b
-pkgrel=2
+pkgrel=3
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=(x86_64)
url=http://www.aegisub.org
@@ -43,11 +43,13 @@ source=(
0001-Use-target-name-without-directory-in-_OBJ-macro.patch
# https://github.com/Aegisub/Aegisub/commit/5f235ff459e6a7ec36639894d1f45a638a9d73f3.patch
0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
+ Remove-second-argument-to-StartStyling.patch
)
sha256sums=('SKIP'
'SKIP'
'ce90cd9a9c56abcbafeb88d33280d53bee5af98cd9e15f50d6a9e49ae1edda30'
- 'c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17')
+ 'c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17'
+ '42d2c03d19eb6d64b0eb26c6c591fc142f61fcc251b0efcb91377f40448d9778')
pkgver() {
cd aegisub
@@ -71,6 +73,9 @@ prepare() {
# Fix build with wxWidgets 3.0
patch -p1 -i ../0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
+ # Fix runtime warning "The second argument passed to StartStyling should be 0"
+ patch -p1 -i ../Remove-second-argument-to-StartStyling.patch
+
cp -f /usr/share/aclocal/ax_boost_{chrono,filesystem,locale,regex,system,thread}.m4 m4macros/
./autogen.sh
diff --git a/Remove-second-argument-to-StartStyling.patch b/Remove-second-argument-to-StartStyling.patch
new file mode 100644
index 000000000000..4297f99aa1ed
--- /dev/null
+++ b/Remove-second-argument-to-StartStyling.patch
@@ -0,0 +1,48 @@
+diff --git a/src/dialog_fonts_collector.cpp b/src/dialog_fonts_collector.cpp
+index 78ac20ef5c..9b71afd752 100644
+--- a/src/dialog_fonts_collector.cpp
++++ b/src/dialog_fonts_collector.cpp
+@@ -400,7 +400,11 @@ void DialogFontsCollector::OnAddText(ValueEvent<color_str_pair> &event) {
+ auto const& utf8 = str.second.utf8_str();
+ collection_log->AppendTextRaw(utf8.data(), utf8.length());
+ if (str.first) {
++#if wxCHECK_VERSION (3, 1, 0)
++ collection_log->StartStyling(pos);
++#else
+ collection_log->StartStyling(pos, 31);
++#endif
+ collection_log->SetStyling(utf8.length(), str.first);
+ }
+ collection_log->GotoPos(pos + utf8.length());
+diff --git a/src/dialog_translation.cpp b/src/dialog_translation.cpp
+index c5fb4ffb85..86f12291c9 100644
+--- a/src/dialog_translation.cpp
++++ b/src/dialog_translation.cpp
+@@ -244,7 +248,11 @@ void DialogTranslation::UpdateDisplay() {
+ int initial_pos = original_text->GetLength();
+ original_text->AppendTextRaw(block->GetText().c_str());
+ if (i == cur_block) {
++#if wxCHECK_VERSION (3, 1, 0)
++ original_text->StartStyling(initial_pos);
++#else
+ original_text->StartStyling(initial_pos, 31);
++#endif
+ original_text->SetStyling(block->GetText().size(), 1);
+ }
+ }
+diff --git a/src/subs_edit_ctrl.cpp b/src/subs_edit_ctrl.cpp
+index 4618ea4097..a44c099e0a 100644
+--- a/src/subs_edit_ctrl.cpp
++++ b/src/subs_edit_ctrl.cpp
+@@ -261,7 +279,11 @@ void SubsTextEditCtrl::UpdateStyle() {
+ cursor_pos = -1;
+ UpdateCallTip();
+
++#if wxCHECK_VERSION (3, 1, 0)
++ StartStyling(0);
++#else
+ StartStyling(0,255);
++#endif
+
+ if (!OPT_GET("Subtitle/Highlight/Syntax")->GetBool()) {
+ SetStyling(line_text.size(), 0);