summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70b3decfc272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = afb-cmake-modules-git
+ pkgdesc = This is a CMake module made to ease development of binding and application framework binder apps.
+ pkgver = 10.0.0
+ pkgrel = 1
+ url = https://github.com/redpesk-core/afb-cmake-modules.git
+ arch = any
+ license = LGPL3
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = lua
+ makedepends = git
+ depends = make
+ provides = afb-cmake-modules
+ conflicts = afb-cmake-modules
+ source = afb-cmake-modules::git+https://github.com/redpesk-core/afb-cmake-modules.git
+ md5sums = SKIP
+
+pkgname = afb-cmake-modules-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2da8526f0ec3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Clément Bénier <clement.benier@iot.bzh>
+pkgname=afb-cmake-modules-git
+pkgver=10.0.0
+pkgrel=1
+pkgdesc="This is a CMake module made to ease development of binding and application framework binder apps."
+arch=('any')
+url="https://github.com/redpesk-core/afb-cmake-modules.git"
+license=('LGPL3')
+depends=('make')
+makedepends=('cmake' 'gcc' 'lua' 'git')
+checkdepends=()
+optdepends=()
+provides=('afb-cmake-modules')
+conflicts=('afb-cmake-modules')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname%-git}::git+https://github.com/redpesk-core/afb-cmake-modules.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe | sed "s/-/+/g"
+}
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ "$srcdir/${pkgname%-git}"
+ make -j
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}