summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4984fc5d99d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = agda-bin-git
+ pkgdesc = A dependently typed functional programming language and proof assistant: development version
+ pkgver = 2.6.2.98d4eb0
+ pkgrel = 1
+ url = http://wiki.portal.chalmers.se/agda/
+ arch = x86_64
+ license = custom
+ makedepends = tar
+ makedepends = sed
+ provides = agda
+ conflicts = agda
+ source = https://github.com/agda/agda/releases/download/nightly/Agda-nightly-linux.tar.xz
+ source = https://github.com/agda/agda/blob/nightly/LICENSE
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = agda-bin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c0cc48105a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yanning Chen <self at lightquantum at me>
+pkgname=agda-bin-git
+pkgver=2.6.2.98d4eb0
+pkgrel=1
+pkgdesc="A dependently typed functional programming language and proof assistant: development version"
+arch=('x86_64')
+url="http://wiki.portal.chalmers.se/agda/"
+license=('custom')
+makedepends=('tar' 'sed')
+provides=("agda")
+conflicts=("agda")
+source=("https://github.com/agda/agda/releases/download/nightly/Agda-nightly-linux.tar.xz" "https://github.com/agda/agda/blob/nightly/LICENSE")
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/Agda-nightly"
+ ./bin/agda -V|sed -rn "s/.*version (.*)-(.*)/\1.\2/p"
+}
+
+package() {
+ cd "$srcdir"
+ pushd "Agda-nightly"
+ pushd bin
+ find ./ -type f -exec install -Dm755 {} "${pkgdir}/usr/bin/{}" \;
+ popd
+ pushd data
+ find ./ -type f -exec install -Dm600 {} "${pkgdir}/usr/share/agda/{}" \;
+ popd
+ popd
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/agda/LICENSE"
+}