summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
3 files changed, 98 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..df85213581f4
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = airgraph-ng-svn
+ pkgdesc = Graphing tool for the aircrack-ng suite
+ pkgver = 2112
+ pkgrel = 2
+ url = http://www.aircrack-ng.org
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = subversion
+ depends = python2
+ depends = graphviz
+ optdepends = psyco: JIT compiler for python
+ provides = airgraph
+ conflicts = airgraph-ng
+ conflicts = aircrack-ng-scripts
+ source = svn://trac.aircrack-ng.org/svn/trunk/scripts/airgraph-ng/
+
+pkgname = airgraph-ng-svn
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53d38da2a4b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = airgraph-ng-svn
+ pkgdesc = Graphing tool for the aircrack-ng suite
+ pkgver = 2112
+ pkgrel = 2
+ url = http://www.aircrack-ng.org
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = subversion
+ depends = python2
+ depends = graphviz
+ optdepends = psyco: JIT compiler for python
+ provides = airgraph
+ conflicts = airgraph-ng
+ conflicts = aircrack-ng-scripts
+ source = svn://trac.aircrack-ng.org/svn/trunk/scripts/airgraph-ng/
+ sha512sums = SKIP
+
+pkgname = airgraph-ng-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18949a664e72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+#! /bin/bash
+# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+# Contributor: Jens Pranaitis <jens@jenux.homelinux.org>
+# Contributor: Techlive Zheng <techlivezheng [at] gmail [dot] com>
+
+pkgname=airgraph-ng-svn
+pkgdesc="Graphing tool for the aircrack-ng suite"
+pkgver=2112
+pkgrel=2
+arch=('i686' 'x86_64')
+url="http://www.aircrack-ng.org"
+license=('GPLv2')
+depends=('python2' 'graphviz')
+optdepends=("psyco: JIT compiler for python")
+makedepends=('subversion')
+provides=(airgraph)
+conflicts=('airgraph-ng'
+ 'aircrack-ng-scripts')
+source=( svn://trac.aircrack-ng.org/svn/trunk/scripts/airgraph-ng/)
+sha512sums=('SKIP')
+
+_svnmod=trunk
+
+pkgver() {
+ cd trunk/
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+
+ msg "Starting make..."
+
+ if [ -d ${_svnmod}-build/ ]; then
+ msg "Build exists, cleaning it up... "
+ rm -rf ${_svnmod}-build
+ fi
+
+ msg "Creating build folder... "
+ svn export ${_svnmod} ${_svnmod}-build
+
+ grep -rl python ${_svnmod}-build | xargs sed -i 's|python|python2|g'
+}
+
+package() {
+ cd ${srcdir}
+
+ install -D -m755 ${_svnmod}-build/dump-join ${pkgdir}/usr/bin/dump-join
+ install -D -m755 ${_svnmod}-build/airgraph-ng ${pkgdir}/usr/bin/airgraph-ng
+ install -d ${pkgdir}/usr/lib/airgraph-ng
+ install -m644 ${_svnmod}-build/graphviz/* ${pkgdir}/usr/lib/airgraph-ng/
+ install -D -m644 ${_svnmod}-build/man/dump-join.1 ${pkgdir}/usr/share/man/man1/dump-join.1
+ install -D -m644 ${_svnmod}-build/man/airgraph-ng.1 ${pkgdir}/usr/share/man/man1/airgraph-ng.1
+ install -D -m644 ${_svnmod}-build/README ${pkgdir}/usr/share/doc/airgraph-ng/README
+ install -D -m644 ${_svnmod}-build/setup.py ${pkgdir}/usr/lib/airgraph-ng/setup.py
+ install -D -m644 ${_svnmod}-build/test/test-1.txt ${pkgdir}/usr/include/airgraph-ng/test-1.txt
+ #Remove build directory
+ rm -rf ${_svnmod}-build
+} \ No newline at end of file