summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--altyo-git.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0fd18e95c1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = altyo-git
+ pkgdesc = Vala / GTK+ 3 drop-down terminal emulator
+ pkgver = 0.4_rc12.1.r16.g777b7ad
+ pkgrel = 1
+ url = https://github.com/linvinus/AltYo
+ install = altyo-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = vala
+ depends = gtk-update-icon-cache
+ depends = vte3
+ provides = altyo
+ conflicts = altyo
+ source = altyo-git::git://github.com/linvinus/AltYo.git
+ md5sums = SKIP
+
+pkgname = altyo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0991a870f31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=altyo
+pkgname=$_pkgname-git
+pkgver=0.4_rc12.1.r16.g777b7ad
+pkgrel=1
+pkgdesc="Vala / GTK+ 3 drop-down terminal emulator"
+arch=('i686' 'x86_64')
+url="https://github.com/linvinus/AltYo"
+license=('GPL3')
+#depends=('gtk-update-icon-cache' 'vte290')
+depends=('gtk-update-icon-cache' 'vte3')
+makedepends=('git' 'vala')
+provides=($_pkgname)
+conflicts=($_pkgname)
+install=$pkgname.install
+source=($pkgname::git://github.com/linvinus/AltYo.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/^debian\///;s/\-linvinus[0-9]?//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/altyo-git.install b/altyo-git.install
new file mode 100644
index 000000000000..d641c9a2c2de
--- /dev/null
+++ b/altyo-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+