summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e87d21f56eca..935c5c2086ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = amimullvad
pkgdesc = Utility to check for a mullvad vpn connection status
- pkgver = 1
+ pkgver = 1.1
pkgrel = 1
url = https://github.com/hgrahamcs/amimullvad
arch = x86_64
license = custom:WTFPL
makedepends = cargo
- provides = amimullvad
source = https://github.com/hgrahamcs/amimullvad/archive/v1.1.tar.gz
sha256sums = 42b1699869f3733aa3506f0cb804d19b515fc64c020b2502a1245cd256637160
diff --git a/PKGBUILD b/PKGBUILD
index eb2403bd0e36..2860cf7c8bfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Henry Graham <henry)dot(arch)at(hgrahamcs)dot(com(>
pkgname=amimullvad
-pkgver=1
+pkgver=1.1
pkgrel=1
pkgdesc='Utility to check for a mullvad vpn connection status'
arch=('x86_64')
url='https://github.com/hgrahamcs/amimullvad'
license=('custom:WTFPL')
makedepends=("cargo")
-provides=(${pkgname})
source=('https://github.com/hgrahamcs/amimullvad/archive/v1.1.tar.gz')
sha256sums=('42b1699869f3733aa3506f0cb804d19b515fc64c020b2502a1245cd256637160')
-prepare(){
- tar xvf v$pkgver.$pkgrel.tar.gz
-}
-
build(){
- cd $pkgname-$pkgver.$pkgrel
+ cd $pkgname-$pkgver
cargo build --release
}
package(){
- install -Dm644 "$pkgname-$pkgver.$pkgrel/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 "$pkgname-$pkgver.$pkgrel/target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$pkgname-$pkgver/target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}