summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD36
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75986d906b5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-aarch64-imath
+ pkgdesc = A C++ and python library of 2D and 3D vector, matrix, and math operations for computer graphics (Android aarch64)
+ pkgver = 3.1.11
+ pkgrel = 1
+ url = https://www.openexr.com/
+ arch = any
+ license = BSD-3-Clause
+ makedepends = android-cmake
+ makedepends = android-aarch64-boost
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/AcademySoftwareFoundation/Imath/archive/v3.1.11/imath-3.1.11.tar.gz
+ sha256sums = 9057849585e49b8b85abe7cc1e76e22963b01bfdc3b6d83eac90c499cd760063
+
+pkgname = android-aarch64-imath
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45056ff03478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+
+_android_arch=aarch64
+
+pkgname=android-${_android_arch}-imath
+pkgver=3.1.11
+pkgrel=1
+pkgdesc="A C++ and python library of 2D and 3D vector, matrix, and math operations for computer graphics (Android ${_android_arch})"
+arch=('any')
+url='https://www.openexr.com/'
+license=('BSD-3-Clause')
+depends=('android-ndk')
+makedepends=('android-cmake'
+ "android-${_android_arch}-boost")
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/AcademySoftwareFoundation/Imath/archive/v$pkgver/imath-$pkgver.tar.gz")
+sha256sums=('9057849585e49b8b85abe7cc1e76e22963b01bfdc3b6d83eac90c499cd760063')
+
+build() {
+ cd "${srcdir}/Imath-$pkgver"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-cmake \
+ -S . \
+ -B build
+ cmake --build build
+}
+
+package() {
+ cd "${srcdir}/Imath-$pkgver"
+ source android-env ${_android_arch}
+
+ DESTDIR="$pkgdir" cmake --install build
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}