summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD53
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f4ae01d96c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = android-armv7a-eabi-fontconfig
+ pkgdesc = A library for configuring and customizing font access (android)
+ pkgver = 2.15.0
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fontconfig/
+ arch = any
+ license = custom
+ makedepends = android-configure
+ makedepends = autoconf-archive
+ makedepends = gperf
+ makedepends = python-lxml
+ makedepends = json-c
+ makedepends = python-six
+ depends = android-armv7a-eabi-expat
+ depends = android-armv7a-eabi-freetype2
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://gitlab.freedesktop.org/fontconfig/fontconfig/-/archive/2.15.0/fontconfig-2.15.0.tar.gz
+ sha256sums = cdebb4b805d33e9bdefcc0ef9743db638d2acb21139bbe1a6a85878d4c3e8c9e
+
+pkgname = android-armv7a-eabi-fontconfig
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..97589fb4de69
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.install
+!*.patch
+!*.diff
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30f611b5cfc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: pingplug < aur at pingplug dot me >
+# Contributor: Schala Zeal < schalaalexiazeal at gmail dot com >
+
+_android_arch=armv7a-eabi
+
+pkgname=android-${_android_arch}-fontconfig
+pkgver=2.15.0
+pkgrel=1
+arch=('any')
+pkgdesc="A library for configuring and customizing font access (android)"
+depends=("android-${_android_arch}-expat"
+ "android-${_android_arch}-freetype2")
+makedepends=('android-configure'
+ 'autoconf-archive'
+ 'gperf'
+ 'python-lxml'
+ 'json-c'
+ 'python-six')
+options=(!strip !buildflags staticlibs !emptydirs)
+license=('custom')
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+source=("https://gitlab.freedesktop.org/fontconfig/fontconfig/-/archive/${pkgver}/fontconfig-${pkgver}.tar.gz")
+sha256sums=('cdebb4b805d33e9bdefcc0ef9743db638d2acb21139bbe1a6a85878d4c3e8c9e')
+
+prepare() {
+ cd "${srcdir}/fontconfig-${pkgver}"
+
+ # do not build buggy test code
+ sed -i /test\\/Makefile/d configure.ac
+ sed -i "s/po-conf test/po-conf/g" Makefile.am
+ rm -r test
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/fontconfig-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --disable-docs
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/fontconfig-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/${ANDROID_PREFIX_BIN}
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}