summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD15
3 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e192dcd36504..56b9830cfb24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = android-armv7a-eabi-l-smash
- pkgdesc = MP4 muxer and other tools (android)
+ pkgdesc = MP4 muxer and other tools (Android, armv7a-eabi)
pkgver = 2.14.5
pkgrel = 1
url = https://github.com/l-smash/l-smash
arch = any
license = custom
- depends = android-ndk
+ depends = android-environment
options = !strip
options = !buildflags
options = staticlibs
@@ -16,4 +16,3 @@ pkgbase = android-armv7a-eabi-l-smash
sha256sums = SKIP
pkgname = android-armv7a-eabi-l-smash
-
diff --git a/.gitignore b/.gitignore
index 78c0d7519d91..47731b2e7117 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,5 @@
-mingw-w64-d3dcompiler
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index 948dd9d30861..63e324d31a1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,11 @@ pkgname=android-${_android_arch}-l-smash
pkgver=2.14.5
pkgrel=1
arch=('any')
-pkgdesc='MP4 muxer and other tools (android)'
license=('custom')
url='https://github.com/l-smash/l-smash'
+pkgdesc="MP4 muxer and other tools (Android, ${_android_arch})"
depends=('android-ndk')
+depends=('android-environment')
options=(!strip !buildflags staticlibs !emptydirs)
source=("https://github.com/l-smash/l-smash/archive/v${pkgver}.tar.gz"
"clang.patch")
@@ -22,6 +23,13 @@ sha256sums=('e6f7c31de684f4b89ee27e5cd6262bf96f2a5b117ba938d2d606cf6220f05935'
prepare() {
cd "${srcdir}"/l-smash-${pkgver}
patch -Np1 -i ../clang.patch
+
+ sed -i 's|-Wl,--version-script,liblsmash\.ver||g' configure
+
+ if [[ "${_android_arch}" == armv7a-eabi || "${_android_arch}" == x86 ]]; then
+ sed -i 's|ftello|ftell|g' common/osdep.h
+ sed -i 's|fseeko|fseek|g' common/osdep.h
+ fi
}
build() {
@@ -32,18 +40,17 @@ build() {
--prefix=${ANDROID_PREFIX} \
--cc=${ANDROID_CC} \
--cross-prefix=${ANDROID_TOOLS_PREFIX} \
- --sysroot=${ANDROID_SYSROOT} \
--enable-shared \
--extra-cflags="$CFLAGS" \
--extra-ldflags="$LDFLAGS"
- make $MAKEFLAGS
+ make STRIP="" $MAKEFLAGS
}
package() {
cd "${srcdir}"/l-smash-${pkgver}
source android-env ${_android_arch}
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" STRIP="" install
rm -r "${pkgdir}"/${ANDROID_PREFIX_BIN}
${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a