summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 042253dec3b6..9517b7e72b86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-armv7a-eabi-libffi
- pkgdesc = Portable foreign function interface library (android)
- pkgver = 3.4.4
+ pkgdesc = Portable foreign function interface library (Android armv7a-eabi)
+ pkgver = 3.4.6
pkgrel = 1
url = http://sourceware.org/libffi
arch = any
@@ -11,10 +11,10 @@ pkgbase = android-armv7a-eabi-libffi
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://github.com/libffi/libffi/releases/download/v3.4.4/libffi-3.4.4.tar.gz
+ source = https://github.com/libffi/libffi/releases/download/v3.4.6/libffi-3.4.6.tar.gz
source = 0001-Fix-missing-declaration.patch
source = 0002-Force-x86-compile.patch
- sha256sums = d66c56ad259a82cf2a9dfc408b32bf5da52371500b84745f7fb8b645712df676
+ sha256sums = b0dea9df23c863a7a50e825440f3ebffabd65df1497108e5d437747843895a4e
sha256sums = eb63525f454b0563f28fcd26a887f6e27fb7773dce706658d5a25500e0c10615
sha256sums = 40c34ca6e147b571bce4c6d3523992543086ca2c48cc0fdf17a19a8ed5373e95
diff --git a/PKGBUILD b/PKGBUILD
index 1a748bc14fcf..d18533955fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
_android_arch=armv7a-eabi
pkgname=android-${_android_arch}-libffi
-pkgver=3.4.4
+pkgver=3.4.6
pkgrel=1
arch=('any')
-pkgdesc="Portable foreign function interface library (android)"
+pkgdesc="Portable foreign function interface library (Android ${_android_arch})"
depends=('android-ndk')
makedepends=('android-configure')
options=(!strip !buildflags staticlibs !emptydirs)
@@ -16,14 +16,14 @@ url="http://sourceware.org/libffi"
source=("https://github.com/libffi/libffi/releases/download/v$pkgver/libffi-$pkgver.tar.gz"
'0001-Fix-missing-declaration.patch'
'0002-Force-x86-compile.patch')
-sha256sums=('d66c56ad259a82cf2a9dfc408b32bf5da52371500b84745f7fb8b645712df676'
+sha256sums=('b0dea9df23c863a7a50e825440f3ebffabd65df1497108e5d437747843895a4e'
'eb63525f454b0563f28fcd26a887f6e27fb7773dce706658d5a25500e0c10615'
'40c34ca6e147b571bce4c6d3523992543086ca2c48cc0fdf17a19a8ed5373e95')
prepare () {
cd "${srcdir}/libffi-${pkgver}"
- patch -Np1 -i "../0001-Fix-missing-declaration.patch"
- patch -Np1 -i "../0002-Force-x86-compile.patch"
+ patch -Np1 -i ../0001-Fix-missing-declaration.patch
+ patch -Np1 -i ../0002-Force-x86-compile.patch
}
build() {