summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55bffc357d1a..fcdf108dc90f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = android-armv7a-eabi-libgcrypt
- pkgdesc = General purpose cryptographic library based on the code from GnuPG (android)
+ pkgdesc = General purpose cryptographic library based on the code from GnuPG (Android, armv7a-eabi)
pkgver = 1.10.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnupg.org
arch = any
license = LGPL
+ makedepends = android-configure
depends = android-armv7a-eabi-libgpg-error
options = !strip
options = !buildflags
@@ -13,7 +14,7 @@ pkgbase = android-armv7a-eabi-libgcrypt
source = https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-1.10.3.tar.bz2
source = https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-1.10.3.tar.bz2.sig
validpgpkeys = AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD
- sha256sums = 8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa
- sha256sums = SKIP
+ md5sums = a8cada0b343e10dbee51c9e92d856a94
+ md5sums = SKIP
pkgname = android-armv7a-eabi-libgcrypt
diff --git a/PKGBUILD b/PKGBUILD
index 713cc4632b1d..572e7a9ec144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,24 @@ _android_arch=armv7a-eabi
pkgname=android-${_android_arch}-libgcrypt
pkgver=1.10.3
-pkgrel=1
+pkgrel=2
arch=('any')
-pkgdesc="General purpose cryptographic library based on the code from GnuPG (android)"
+pkgdesc="General purpose cryptographic library based on the code from GnuPG (Android, ${_android_arch})"
url="https://www.gnupg.org"
license=('LGPL')
depends=("android-${_android_arch}-libgpg-error")
+makedepends=("android-configure")
options=(!strip !buildflags staticlibs !emptydirs)
# https://www.gnupg.org/download/integrity_check.html
-source=(https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-${pkgver}.tar.bz2{,.sig})
-sha256sums=('8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa'
- 'SKIP')
+source=("https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-${pkgver}.tar.bz2"{,.sig})
+md5sums=('a8cada0b343e10dbee51c9e92d856a94'
+ 'SKIP')
validpgpkeys=('AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD') # Niibe Yutaka (GnuPG Release Key)
prepare() {
cd "$srcdir/libgcrypt-${pkgver}"
source android-env ${_android_arch}
- # tests fail due to systemd+libseccomp preventing memory syscalls when building in chroots
- # t-secmem: line 176: gcry_control (GCRYCTL_INIT_SECMEM, pool_size, 0) failed: General error
- # FAIL: t-secmem
- # t-sexp: line 1174: gcry_control (GCRYCTL_INIT_SECMEM, 16384, 0) failed: General error
- # FAIL: t-sexp
sed -i "s:t-secmem::" tests/Makefile.am
sed -i "s:t-sexp::" tests/Makefile.am
autoreconf -vfi