summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
-rw-r--r--package.xml (renamed from package.xml.in)8
4 files changed, 35 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1ae91182122..6e3f96dc969e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = android-sdk-cmake
pkgdesc = CMake from Google Android SDK
- pkgver = 3.6.4111459
- pkgrel = 2
- url = http://developer.android.com/sdk/index.html
+ pkgver = 3.22.1
+ pkgrel = 1
+ url = https://developer.android.com/studio/index.html
install = android-sdk-cmake.install
arch = x86_64
license = custom:android-sdk-license
makedepends = libxml2
depends = bash
- noextract = cmake-3.6.4111459-linux-x86_64.zip
options = !strip
- source = https://dl-ssl.google.com/android/repository/cmake-3.6.4111459-linux-x86_64.zip
- source = package.xml.in
- sha1sums = 71c539b9c33f0943e9ad6251fea0b161c0b70782
- sha1sums = 5ca8c4e61ee3a3294865afbd5d16e83662871e06
+ source = https://dl-ssl.google.com/android/repository/cmake-3.22.1-linux.zip
+ source = package.xml
+ sha1sums = fd0a48b4a758310df8c7aa51f59840ed48fe7ed8
+ sha1sums = bb86ed5351e2713b960692ccf90e72b62489ce00
pkgname = android-sdk-cmake
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..49bf39e8f6b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.zip
+*.pkg.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 456fe95dd497..b926485e8d57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,35 @@
-# Maintainer: Yen Chi Hsuan <yan12125 at gmail dot com>
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
pkgname=android-sdk-cmake
_major=3
-_minor=6
-_micro=4111459
+_minor=22
+_micro=1
pkgver=$_major.$_minor.$_micro
-pkgrel=2
+_magic=ba34c321f92f6e6fd696c8354c262c122f56abf8
+pkgrel=1
pkgdesc='CMake from Google Android SDK'
arch=('x86_64')
-url="http://developer.android.com/sdk/index.html"
+url="https://developer.android.com/studio/index.html"
license=('custom:android-sdk-license')
depends=('bash')
makedepends=('libxml2') # xmllint
-source=("https://dl-ssl.google.com/android/repository/cmake-${pkgver}-linux-x86_64.zip"
- package.xml.in)
-noextract=("cmake-${pkgver}-linux-x86_64.zip")
+source=("https://dl-ssl.google.com/android/repository/cmake-${pkgver}-linux.zip"
+ package.xml)
install=android-sdk-cmake.install
# sha1sum is from https://dl.google.com/android/repository/repository2-1.xml
-sha1sums=('71c539b9c33f0943e9ad6251fea0b161c0b70782'
- '5ca8c4e61ee3a3294865afbd5d16e83662871e06')
+sha1sums=('fd0a48b4a758310df8c7aa51f59840ed48fe7ed8'
+ 'bb86ed5351e2713b960692ccf90e72b62489ce00')
options=('!strip')
-prepare() {
- cd "$srcdir"
- mkdir -p cmake-pkg
- cd cmake-pkg
- bsdtar -x -f ../cmake-$pkgver-linux-x86_64.zip
-}
-
-build() {
- cd "$srcdir"
- sed "s#%MAJOR%#$_major#g;s#%MINOR%#$_minor#g;s#%MICRO%#$_micro#g" package.xml.in > package.xml
-}
-
package() {
- install -Ddm755 "$pkgdir"/opt/android-sdk/cmake
- cp -dr --no-preserve=ownership "$srcdir"/cmake-pkg "$pkgdir"/opt/android-sdk/cmake/$pkgver
- # This is required for sdkmanager to recognize this package
- install -Dm644 "$srcdir"/package.xml "$pkgdir"/opt/android-sdk/cmake/$pkgver/package.xml
+ install -Ddm755 "${pkgdir}/opt/android-sdk/cmake/${pkgver}"
+ cp -dr --no-preserve=ownership {bin,doc,share,source.properties} \
+ "${pkgdir}/opt/android-sdk/cmake/${pkgver}"
- install -Ddm755 "$pkgdir"/usr/share/licenses/$pkgname
- xmllint --xpath '//*[local-name()="repository"]/license/text()' "$srcdir"/package.xml \
- > "$pkgdir"/usr/share/licenses/$pkgname/android-sdk-license
+ # This is required for sdkmanager to recognize this package
+ install -Dm644 package.xml "${pkgdir}/opt/android-sdk/cmake/${pkgver}/package.xml"
+ install -Ddm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ xmllint --xpath '//*[local-name()="repository"]/license/text()' package.xml \
+ > "${pkgdir}/usr/share/licenses/${pkgname}/android-sdk-license"
}
diff --git a/package.xml.in b/package.xml
index cbf591318642..3fb02c0426ee 100644
--- a/package.xml.in
+++ b/package.xml
@@ -1,4 +1,4 @@
-<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ns2:repository xmlns:ns2="http://schemas.android.com/repository/android/common/01" xmlns:ns3="http://schemas.android.com/sdk/android/repo/addon2/01" xmlns:ns4="http://schemas.android.com/sdk/android/repo/sys-img2/01" xmlns:ns5="http://schemas.android.com/repository/android/generic/01" xmlns:ns6="http://schemas.android.com/sdk/android/repo/repository2/01"><license id="android-sdk-license" type="text">Terms and Conditions
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ns2:repository xmlns:ns2="http://schemas.android.com/repository/android/common/01" xmlns:ns3="http://schemas.android.com/repository/android/generic/01" xmlns:ns4="http://schemas.android.com/sdk/android/repo/addon2/01" xmlns:ns5="http://schemas.android.com/sdk/android/repo/repository2/01" xmlns:ns6="http://schemas.android.com/sdk/android/repo/sys-img2/01"><license id="android-sdk-license" type="text">Terms and Conditions
This is the Android Software Development Kit License Agreement
@@ -32,7 +32,7 @@ This is the Android Software Development Kit License Agreement
3.3 You agree that Google or third parties own all legal right, title and interest in and to the SDK, including any Intellectual Property Rights that subsist in the SDK. "Intellectual Property Rights" means any and all rights under patent law, copyright law, trade secret law, trademark law, and any and all other proprietary rights. Google reserves all rights not expressly granted to you.
-3.4 You may not use the SDK for any purpose not expressly permitted by the License Agreement. Except to the extent required by applicable third party licenses, you may not: (a) copy (except for backup purposes), modify, adapt, redistribute, decompile, reverse engineer, disassemble, or create derivative works of the SDK or any part of the SDK; or (b) load any part of the SDK onto a mobile handset or any other hardware device except a personal computer, combine any part of the SDK with other software, or distribute any software or device incorporating a part of the SDK.
+3.4 You may not use the SDK for any purpose not expressly permitted by the License Agreement. Except to the extent required by applicable third party licenses, you may not copy (except for backup purposes), modify, adapt, redistribute, decompile, reverse engineer, disassemble, or create derivative works of the SDK or any part of the SDK.
3.5 Use, reproduction and distribution of components of the SDK licensed under an open source software license are governed solely by the terms of that open source software license and not the License Agreement.
@@ -83,7 +83,7 @@ This is the Android Software Development Kit License Agreement
8.1.1 If you use any API to retrieve data from Google, you acknowledge that the data may be protected by intellectual property rights which are owned by Google or those parties that provide the data (or by other persons or companies on their behalf). Your use of any such API may be subject to additional Terms of Service. You may not modify, rent, lease, loan, sell, distribute or create derivative works based on this data (either in whole or in part) unless allowed by the relevant Terms of Service.
-8.1.2 If you use any API to retrieve a user's data from Google, you acknowledge and agree that you shall retrieve data only with the user's explicit consent and only when, and for the limited purposes for which, the user has given you permission to do so.
+8.1.2 If you use any API to retrieve a user's data from Google, you acknowledge and agree that you shall retrieve data only with the user's explicit consent and only when, and for the limited purposes for which, the user has given you permission to do so. If you use the Android Recognition Service API, documented at the following URL: https://developer.android.com/reference/android/speech/RecognitionService, as updated from time to time, you acknowledge that the use of the API is subject to the Data Processing Addendum for Products where Google is a Data Processor, which is located at the following URL: https://privacy.google.com/businesses/gdprprocessorterms/, as updated from time to time. By clicking to accept, you hereby agree to the terms of the Data Processing Addendum for Products where Google is a Data Processor.
9. Terminating the License Agreement
@@ -138,4 +138,4 @@ This is the Android Software Development Kit License Agreement
14.7 The License Agreement, and your relationship with Google under the License Agreement, shall be governed by the laws of the State of California without regard to its conflict of laws provisions. You and Google agree to submit to the exclusive jurisdiction of the courts located within the county of Santa Clara, California to resolve any legal matter arising from the License Agreement. Notwithstanding this, you agree that Google shall still be allowed to apply for injunctive remedies (or an equivalent type of urgent legal relief) in any jurisdiction.
-November 20, 2015</license><localPackage path="cmake;%MAJOR%.%MINOR%.%MICRO%" obsolete="false"><type-details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns5:genericDetailsType"/><revision><major>%MAJOR%</major><minor>%MINOR%</minor><micro>%MICRO%</micro></revision><display-name>CMake %MAJOR%.%MINOR%.%MICRO%</display-name><uses-license ref="android-sdk-license"/></localPackage></ns2:repository>
+January 16, 2019</license><localPackage path="cmake;3.22.1" obsolete="false"><type-details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns3:genericDetailsType"/><revision><major>3</major><minor>22</minor><micro>1</micro></revision><display-name>CMake 3.22.1</display-name><uses-license ref="android-sdk-license"/></localPackage></ns2:repository> \ No newline at end of file