summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e238ed218178
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-x86-64-libtasn1
+ pkgdesc = The ASN.1 library used in GNUTLS (android)
+ pkgver = 4.19.0
+ pkgrel = 1
+ url = http://www.gnu.org/software/libtasn1
+ arch = any
+ license = GPL3, LGPL
+ makedepends = android-configure
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = http://ftp.gnu.org/gnu/libtasn1/libtasn1-4.19.0.tar.gz
+ sha256sums = 1613f0ac1cf484d6ec0ce3b8c06d56263cc7242f1c23b30d82d23de345a63f7a
+
+pkgname = android-x86-64-libtasn1
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bff248642c42
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e94b08fe8721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: drakkan <nicola.murino at gmail dot com>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-libtasn1
+pkgver=4.19.0
+pkgrel=1
+pkgdesc="The ASN.1 library used in GNUTLS (android)"
+arch=('any')
+url="http://www.gnu.org/software/libtasn1"
+license=("GPL3, LGPL")
+depends=('android-ndk')
+options=(!strip !buildflags staticlibs !emptydirs)
+makedepends=('android-configure')
+source=("http://ftp.gnu.org/gnu/libtasn1/libtasn1-${pkgver}.tar.gz")
+sha256sums=('1613f0ac1cf484d6ec0ce3b8c06d56263cc7242f1c23b30d82d23de345a63f7a')
+
+prepare() {
+ source android-env ${_android_arch}
+ check_ndk_version_ge_than 18.0
+}
+
+build() {
+ cd "${srcdir}"/libtasn1-${pkgver}
+ source android-env ${_android_arch}
+
+ export CFLAGS="${CFLAGS} -D_FORTIFY_SOURCE=2 -D__USE_FORTIFY_LEVEL=2"
+ export CPPFLAGS="${CPPFLAGS} -D_FORTIFY_SOURCE=2 -D__USE_FORTIFY_LEVEL=2"
+
+ android-${_android_arch}-configure \
+ --disable-doc
+}
+
+package() {
+ cd "${srcdir}"/libtasn1-${pkgver}
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}