summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD44
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a22d9fe1e5c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-x86-64-libtpms
+ pkgdesc = Library providing a software emulation of a Trusted Platform Module (TPM 1.2 and TPM 2.0) (Android x86-64)
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = https://github.com/stefanberger/libtpms
+ arch = any
+ license = BSD
+ makedepends = android-configure
+ depends = android-x86-64-openssl
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/stefanberger/libtpms/archive/refs/tags/v0.9.6.tar.gz
+ md5sums = c922a80cb1a098e6f9b2671c0044a388
+
+pkgname = android-x86-64-libtpms
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a19ad263003c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Jonas Witschel <diabonas@archlinux.org>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-libtpms
+pkgver=0.9.6
+pkgrel=1
+arch=('any')
+pkgdesc="Library providing a software emulation of a Trusted Platform Module (TPM 1.2 and TPM 2.0) (Android ${_android_arch})"
+url='https://github.com/stefanberger/libtpms'
+license=('BSD')
+depends=("android-${_android_arch}-openssl")
+makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/stefanberger/libtpms/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('c922a80cb1a098e6f9b2671c0044a388')
+
+prepare() {
+ cd "${srcdir}/libtpms-$pkgver"
+ source android-env ${_android_arch}
+
+ autoreconf --install --force
+}
+
+build() {
+ cd "${srcdir}/libtpms-$pkgver"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --with-openssl \
+ --with-tpm2
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/libtpms-$pkgver"
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}