summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD44
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8e64afda951
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-x86-64-openexr
+ pkgdesc = A high dynamic-range image file format library (Android x86-64)
+ pkgver = 3.2.4
+ pkgrel = 1
+ url = https://www.openexr.com/
+ arch = any
+ license = BSD-3-Clause
+ makedepends = android-cmake
+ depends = android-x86-64-imath
+ depends = android-x86-64-libdeflate
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/openexr/openexr/archive/v3.2.4/openexr-3.2.4.tar.gz
+ sha256sums = 81e6518f2c4656fdeaf18a018f135e96a96e7f66dbe1c1f05860dd94772176cc
+
+pkgname = android-x86-64-openexr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb13212f094b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-openexr
+pkgver=3.2.4
+pkgrel=1
+arch=('any')
+pkgdesc="A high dynamic-range image file format library (Android ${_android_arch})"
+url='https://www.openexr.com/'
+license=('BSD-3-Clause')
+depends=("android-${_android_arch}-imath"
+ "android-${_android_arch}-libdeflate")
+makedepends=('android-cmake')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/openexr/openexr/archive/v$pkgver/openexr-$pkgver.tar.gz")
+sha256sums=('81e6518f2c4656fdeaf18a018f135e96a96e7f66dbe1c1f05860dd94772176cc')
+
+build() {
+ cd "${srcdir}/openexr-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-cmake \
+ -S . \
+ -B build \
+ -DBUILD_TESTING=OFF \
+ -DOPENEXR_TEST_LIBRARIES=OFF \
+ -DOPENEXR_TEST_PYTHON=OFF \
+ -DOPENEXR_TEST_TOOLS=OFF \
+ -DOPENEXR_BUILD_EXAMPLES=OFF \
+ -DOPENEXR_BUILD_TOOLS=OFF \
+ -DImath_DIR="${ANDROID_PREFIX_LIB}/cmake/Imath" \
+ -Dlibdeflate_DIR="${ANDROID_PREFIX_LIB}/cmake/libdeflate"
+ make -C build $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/openexr-${pkgver}"
+ source android-env ${_android_arch}
+
+ make -C build DESTDIR="$pkgdir" install
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}