summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD37
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1162529a23c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+#@IgnoreInspection BashAddShebang
+pkgbase = android-x86-64-system-image-27
+ pkgdesc = Android x86_64 system image, API 27
+ pkgver = 27_8.1.0_r01
+ pkgrel = 1
+ url = https://developer.android.com/studio/index.html
+ arch = any
+ license = custom
+ depends = android-platform-27
+ provides = android-x86-64-system-image
+ options = !strip
+ source = https://dl.google.com/android/repository/sys-img/android/x86_64-27_r01.zip
+ sha1sums = 2878261011a59ca3de29dc5b457a495fdb268d60
+ sha256sums = 40b5a99b4515c32e06ffd7df4939befb22b83f4df9c6b122b8eea2cfeef553e4
+
+pkgname = android-x86-64-system-image-27
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba88b43a40f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# IntelliJ project files
+.idea
+*.iml
+out
+gen
+
+# Generated files
+*.zip
+*.pkg.tar.xz
+src
+pkg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fa656117f4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#@IgnoreInspection BashAddShebang
+# Maintainer: Jérémy "Vrakfall" Lecocq <jeremy at artphotolaurent dot be>
+# Contributor: David Manouchehri <manouchehri@riseup.net>
+# Contributor: Christoph Bayer <chrbayer@criby.de>
+# Contributor: Bence Hornák <hornak dot bence at gmail dot com>
+# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
+# Contributor: danyf90 <daniele.formichelli@gmail.com>
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
+# Contributor: Joel Pedraza <joel@joelpedraza.com>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+
+_apilevel=27
+_sdkver='8.1.0'
+_rev='r01'
+_image_arch='x86_64'
+pkgname="android-${_image_arch/x86_/x86-}-system-image-${_apilevel}"
+pkgver="${_apilevel}_${_sdkver}_${_rev}" # I use this version labeling as an attempt to work with all notations
+# across `AUR`. Some use the `API` level, some use the `SDK` version. This way, all the numbers are visible and this
+# should be a "higher number" than other versioning schemes (except between `API` levels and some very old versions).
+pkgrel=1
+pkgdesc="Android ${_image_arch} system image, API ${_apilevel}"
+arch=('any') # I actually don't think it works on x86, or not in a fine way.
+url="https://developer.android.com/studio/index.html"
+license=('custom') # TODO: Link to the license.
+depends=("android-platform-${_apilevel}")
+provides=("android-${_image_arch/x86_/x86-}-system-image")
+options=('!strip')
+source=("https://dl.google.com/android/repository/sys-img/android/${_image_arch}-${_apilevel}_${_rev}.zip")
+sha1sums=('2878261011a59ca3de29dc5b457a495fdb268d60')
+sha256sums=('40b5a99b4515c32e06ffd7df4939befb22b83f4df9c6b122b8eea2cfeef553e4')
+
+package() {
+ _destdir="${pkgdir}/opt/android-sdk/system-images/android-${_apilevel}/default"
+ mkdir -p "${_destdir}"
+ mv "${srcdir}/${_image_arch}" "${_destdir}"
+ chmod -R ugo+rX "${pkgdir}/opt"
+} \ No newline at end of file