summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Disable-zlib-version-check.patch27
-rw-r--r--PKGBUILD17
3 files changed, 45 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f927a62b5fc3..cb67deef8b8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-x86-libpng
- pkgdesc = A collection of routines used to create PNG format graphics (android)
- pkgver = 1.6.42
+ pkgdesc = A collection of routines used to create PNG format graphics (Android x86)
+ pkgver = 1.6.43
pkgrel = 1
url = http://www.libpng.org/pub/png/libpng.html
arch = any
@@ -11,7 +11,9 @@ pkgbase = android-x86-libpng
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.6.42.tar.xz
- sha256sums = c919dbc11f4c03b05aba3f8884d8eb7adfe3572ad228af972bb60057bdb48450
+ source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.6.43.tar.xz
+ source = 0001-Disable-zlib-version-check.patch
+ md5sums = 22b8362d16c3724eba9c1fb8d187320a
+ md5sums = 02be00cae20d83569e60fffd98047d1b
pkgname = android-x86-libpng
diff --git a/0001-Disable-zlib-version-check.patch b/0001-Disable-zlib-version-check.patch
new file mode 100644
index 000000000000..cc82d380f8ad
--- /dev/null
+++ b/0001-Disable-zlib-version-check.patch
@@ -0,0 +1,27 @@
+--- a/pngpriv.h
++++ a/pngpriv.h
+@@ -938,24 +938,6 @@
+ #include "pngstruct.h"
+ #include "pnginfo.h"
+
+-/* Validate the include paths - the include path used to generate pnglibconf.h
+- * must match that used in the build, or we must be using pnglibconf.h.prebuilt:
+- */
+-#if PNG_ZLIB_VERNUM != 0 && PNG_ZLIB_VERNUM != ZLIB_VERNUM
+-# error ZLIB_VERNUM != PNG_ZLIB_VERNUM \
+- "-I (include path) error: see the notes in pngpriv.h"
+- /* This means that when pnglibconf.h was built the copy of zlib.h that it
+- * used is not the same as the one being used here. Because the build of
+- * libpng makes decisions to use inflateInit2 and inflateReset2 based on the
+- * zlib version number and because this affects handling of certain broken
+- * PNG files the -I directives must match.
+- *
+- * The most likely explanation is that you passed a -I in CFLAGS. This will
+- * not work; all the preprocessor directives and in particular all the -I
+- * directives must be in CPPFLAGS.
+- */
+-#endif
+-
+ /* This is used for 16-bit gamma tables -- only the top level pointers are
+ * const; this could be changed:
+ */
diff --git a/PKGBUILD b/PKGBUILD
index 3dac216cf426..6785af036f67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,25 @@
_android_arch=x86
pkgname=android-${_android_arch}-libpng
-pkgver=1.6.42
+pkgver=1.6.43
pkgrel=1
-pkgdesc="A collection of routines used to create PNG format graphics (android)"
+pkgdesc="A collection of routines used to create PNG format graphics (Android ${_android_arch})"
arch=('any')
url="http://www.libpng.org/pub/png/libpng.html"
license=('custom')
depends=("android-${_android_arch}-zlib")
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-configure')
-source=("http://downloads.sourceforge.net/sourceforge/libpng/libpng-$pkgver.tar.xz")
-sha256sums=('c919dbc11f4c03b05aba3f8884d8eb7adfe3572ad228af972bb60057bdb48450')
+source=("http://downloads.sourceforge.net/sourceforge/libpng/libpng-$pkgver.tar.xz"
+ '0001-Disable-zlib-version-check.patch')
+md5sums=('22b8362d16c3724eba9c1fb8d187320a'
+ '02be00cae20d83569e60fffd98047d1b')
+
+prepare() {
+ cd "$srcdir/libpng-$pkgver"
+
+ patch -Np1 -i ../0001-Disable-zlib-version-check.patch
+}
build() {
cd "$srcdir/libpng-$pkgver"
@@ -25,7 +33,6 @@ build() {
--enable-unversioned-libpng-pc\
--enable-unversioned-libpng-config \
--enable-hardware-optimizations
-
make $MAKEFLAGS
}