summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD42
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2013513c9fe1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = android-x86-libsm
+ pkgdesc = X11 Session Management library (Android x86)
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ makedepends = android-configure
+ makedepends = android-x86-xorg-util-macros
+ makedepends = android-x86-xtrans
+ makedepends = android-x86-xorgproto
+ depends = android-x86-libice
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://xorg.freedesktop.org//releases/individual/lib/libSM-1.2.4.tar.xz
+ source = https://xorg.freedesktop.org//releases/individual/lib/libSM-1.2.4.tar.xz.sig
+ validpgpkeys = 4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E
+ md5sums = ffa434ed96ccae45533b3d653300730e
+ md5sums = SKIP
+
+pkgname = android-x86-libsm
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bd656faa1e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_android_arch=x86
+
+pkgname=android-${_android_arch}-libsm
+pkgver=1.2.4
+pkgrel=1
+arch=('any')
+pkgdesc="X11 Session Management library (Android ${_android_arch})"
+license=('custom')
+url="https://xorg.freedesktop.org/"
+depends=("android-${_android_arch}-libice")
+makedepends=("android-configure"
+ "android-${_android_arch}-xorg-util-macros"
+ "android-${_android_arch}-xtrans"
+ "android-${_android_arch}-xorgproto")
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("${url}/releases/individual/lib/libSM-${pkgver}.tar.xz"{,.sig})
+md5sums=('ffa434ed96ccae45533b3d653300730e'
+ 'SKIP')
+validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alanc@freedesktop.org>
+
+build() {
+ cd "${srcdir}/libSM-$pkgver"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --sysconfdir="${ANDROID_PREFIX_ETC}"
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/libSM-$pkgver"
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}