summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD43
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52b539b7ad41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = android-x86-libxss
+ pkgdesc = X11 Screen Saver extension library (Android x86)
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xorg/lib/libxscrnsaver
+ arch = any
+ license = custom
+ makedepends = android-x86-xorg-util-macros
+ makedepends = android-x86-xorgproto
+ depends = android-x86-libxext
+ depends = android-x86-libx11
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://xorg.freedesktop.org/releases/individual/lib/libXScrnSaver-1.2.4.tar.xz
+ source = https://xorg.freedesktop.org/releases/individual/lib/libXScrnSaver-1.2.4.tar.xz.sig
+ validpgpkeys = 4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E
+ md5sums = e613751d38e13aa0d0fd8e0149cec057
+ md5sums = SKIP
+
+pkgname = android-x86-libxss
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b62f0dc413b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+
+_android_arch=x86
+
+pkgname=android-${_android_arch}-libxss
+pkgver=1.2.4
+pkgrel=1
+arch=('any')
+pkgdesc="X11 Screen Saver extension library (Android ${_android_arch})"
+license=('custom')
+url="https://gitlab.freedesktop.org/xorg/lib/libxscrnsaver"
+depends=("android-${_android_arch}-libxext"
+ "android-${_android_arch}-libx11")
+makedepends=("android-${_android_arch}-xorg-util-macros"
+ "android-${_android_arch}-xorgproto")
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://xorg.freedesktop.org/releases/individual/lib/libXScrnSaver-${pkgver}.tar.xz"{,.sig})
+md5sums=('e613751d38e13aa0d0fd8e0149cec057'
+ 'SKIP')
+validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
+
+build() {
+ cd "${srcdir}/libXScrnSaver-$pkgver"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --sysconfdir="${ANDROID_PREFIX_ETC}" \
+ --enable-malloc0returnsnull=no
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/libXScrnSaver-$pkgver"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "$pkgdir/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}