summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0002-Fix-array-with-negative-size.patch11
-rw-r--r--PKGBUILD9
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3653b897df82..955df048a447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-nspr
pkgdesc = Netscape Portable Runtime (android)
pkgver = 4.35
- pkgrel = 1
+ pkgrel = 2
url = https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR
arch = any
license = MPL-2.0
@@ -14,7 +14,9 @@ pkgbase = android-x86-nspr
options = !emptydirs
source = https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v4.35/src/nspr-4.35.tar.gz
source = 0001-Fix-configure-file.patch
+ source = 0002-Fix-array-with-negative-size.patch
sha256sums = 7ea3297ea5969b5d25a5dd8d47f2443cda88e9ee746301f6e1e1426f8a6abc8f
sha256sums = 1d83aad5546f7ee9f5e06f36e7ce9e49613edb2e3609e4e01c84a604f9195106
+ sha256sums = b56d9e08577418ba2622aa0d0fe69beb06d253b762831f3fad23bc5ca4ad0f74
pkgname = android-x86-nspr
diff --git a/0002-Fix-array-with-negative-size.patch b/0002-Fix-array-with-negative-size.patch
new file mode 100644
index 000000000000..dc3396fa2aa5
--- /dev/null
+++ b/0002-Fix-array-with-negative-size.patch
@@ -0,0 +1,11 @@
+--- a/nspr/pr/include/prtypes.h
++++ b/nspr/pr/include/prtypes.h
+@@ -553,7 +553,7 @@
+ ** allowed.
+ */
+ #define PR_STATIC_ASSERT(condition) \
+- extern void pr_static_assert(int arg[(condition) ? 1 : -1])
++ extern void pr_static_assert(int arg[(condition) ? 1 : 0])
+
+ PR_END_EXTERN_C
+
diff --git a/PKGBUILD b/PKGBUILD
index c007f77155e5..28e9b2e99001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _android_arch=x86
pkgname=android-${_android_arch}-nspr
pkgver=4.35
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc="Netscape Portable Runtime (android)"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR"
@@ -17,15 +17,18 @@ makedepends=('android-configure'
'zip')
options=(!strip !buildflags staticlibs !emptydirs)
source=("https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${pkgver}/src/nspr-${pkgver}.tar.gz"
- '0001-Fix-configure-file.patch')
+ '0001-Fix-configure-file.patch'
+ '0002-Fix-array-with-negative-size.patch')
sha256sums=('7ea3297ea5969b5d25a5dd8d47f2443cda88e9ee746301f6e1e1426f8a6abc8f'
- '1d83aad5546f7ee9f5e06f36e7ce9e49613edb2e3609e4e01c84a604f9195106')
+ '1d83aad5546f7ee9f5e06f36e7ce9e49613edb2e3609e4e01c84a604f9195106'
+ 'b56d9e08577418ba2622aa0d0fe69beb06d253b762831f3fad23bc5ca4ad0f74')
prepare() {
cd "${srcdir}/nspr-${pkgver}"
source android-env ${_android_arch}
patch -Np1 -i ../0001-Fix-configure-file.patch
+ patch -Np1 -i ../0002-Fix-array-with-negative-size.patch
sed -i "s|@ANDROID_CC@|${ANDROID_CC}|g" nspr/configure
sed -i "s|@ANDROID_CXX@|${ANDROID_CXX}|g" nspr/configure