summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1390628bef3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = anidb-mv
+ pkgdesc = Command line client for AniDB
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ljb/anidb-mv
+ arch = any
+ license = GPL3
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/anidb-mv/anidb-mv-0.1.tar.gz
+ sha256sums = d08db0fe1fb7969c3dba27c32b37e0fae6a12073c422f74fecc3205bc6b61eb7
+
+pkgname = anidb-mv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8684c658bac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jonas Bengtsson <jonas@bengtsson.cc>
+
+pkgname=anidb-mv
+pkgver=0.1
+pkgrel=1
+pkgdesc="Command line client for AniDB"
+arch=(any)
+url="https://github.com/ljb/anidb-mv"
+license=(GPL3)
+depends=(python)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('d08db0fe1fb7969c3dba27c32b37e0fae6a12073c422f74fecc3205bc6b61eb7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}