summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 578e874b6f45..bd4817e3d75b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
-# Generated by mksrcinfo v8
-# Sat Feb 16 16:08:31 UTC 2019
pkgbase = anoise-community-extension4
pkgdesc = Ambient Noise Community Library Package 4
pkgver = 0.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://code.launchpad.net/anoise
arch = any
license = GPL3
- makedepends = python-distutils-extra
source = anoise-community-extension4-0.0.1.tar.gz::https://launchpad.net/~costales/+archive/ubuntu/anoise/+sourcefiles/anoise-community-extension4/0.0.1/anoise-community-extension4_0.0.1.tar.gz
sha256sums = 4705dfba1ebe16aee5a8f72f0841585069e0dd2fbb12f589c6231c2be655cece
pkgname = anoise-community-extension4
-
diff --git a/PKGBUILD b/PKGBUILD
index c59fe0ef90ea..735451c7eb94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: twa022 <twa022 at gmail dot com>
-pkgname=anoise-community-extension4
-pkgver=0.0.1
-pkgrel=2
-pkgdesc="Ambient Noise Community Library Package 4"
+_pkg=4
+_pkgver=('0' '0.0.1' '0.0.4' '0.0.1' '0.0.1' '0.0.1')
+_pkgrel=(0 6 4 6 3 3)
+_folder=(''
+ 'community'
+ 'community-extension2'
+ 'media3'
+ 'community-extension4'
+ 'community-extension5')
+
+pkgname=anoise-community-extension${_pkg}
+pkgver=${_pkgver[${_pkg}]}
+pkgrel=${_pkgrel[${_pkg}]}
+pkgdesc="Ambient Noise Community Library Package ${_pkg}"
arch=('any')
license=('GPL3')
-url="https://code.launchpad.net/anoise"
-makedepends=('python-distutils-extra')
+url='https://code.launchpad.net/anoise'
source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/~costales/+archive/ubuntu/anoise/+sourcefiles/${pkgname}/${pkgver}/${pkgname}_${pkgver}.tar.gz")
sha256sums=('4705dfba1ebe16aee5a8f72f0841585069e0dd2fbb12f589c6231c2be655cece')
package() {
- cd "${srcdir}/${pkgname/anoise-/}"
- python ./setup.py install --prefix=/usr --root="${pkgdir}"
+ install -Dm644 ${_folder[${_pkg}]}/sounds/* -t "${pkgdir}"/usr/share/anoise/sounds/
}