summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 083c1ce1801a..2dd281365c80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = ansible-keepass-git
url = https://github.com/viczem/ansible-keepass
arch = any
license = MIT
+ makedepends = git
depends = ansible
depends = python-pykeepass
provides = ansible-keepass
diff --git a/PKGBUILD b/PKGBUILD
index 3e6a28fe5309..a94c58570596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ arch=('any')
url='https://github.com/viczem/ansible-keepass'
license=('MIT')
depends=('ansible' 'python-pykeepass')
+makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("git+https://github.com/viczem/${_pkgname}.git")
@@ -22,5 +23,5 @@ package() {
cd "${_pkgname}"
install -Dm644 README.md "$pkgdir/usr/share/doc/${_pkgname}/README.md"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 keepass.py "$pkgdir/usr/share/ansible/plugins/modules/keepass.py"
+ install -Dm644 keepass.py "$pkgdir/usr/share/ansible/plugins/lookup/keepass.py"
}