summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2361fe52dfb6..254fc0b51acb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=antibody
pkgver=3.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A shell plugin manager."
arch=('i686' 'x86_64')
url="https://getantibody.github.io/"
@@ -26,12 +26,15 @@ prepare() {
}
build() {
- cd "$_repodir/$pkgname"
+ export GOPATH="$srcdir/.go"
+ cd "$srcdir/$_repodir/$pkgname"
make
}
check() {
- cd "$_repodir/$pkgname"
+ export GOPATH="$srcdir/.go"
+ export PATH="$GOPATH/bin:$PATH"
+ cd "$srcdir/$_repodir/$pkgname"
make test
}