summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50ffef4bbe7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = antlr27
+ pkgdesc = ANother Tool for Language Recognition
+ pkgver = 2.7.7
+ pkgrel = 1
+ url = http://www.antlr.org/
+ arch = x86_64
+ license = BSD
+ depends = dpkg
+ source = http://ftp.funet.fi/pub/Linux/INSTALL/Ubuntu/archive/pool/main/a/antlr/libantlr-java_2.7.7+dfsg-6_all.deb
+ source = http://ftp.funet.fi/pub/Linux/INSTALL/Ubuntu/archive/pool/main/a/antlr/antlr_2.7.7+dfsg-6_all.deb
+ sha1sums = 50f49bdfc9fa190715d13ca3f06a8ba9d6e34259
+ sha1sums = 82f0033e967079c64351d5fb42e473daebb5889a
+
+pkgname = antlr27
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1568ed516953
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: wtx <sdrb@onet.eu>
+
+pkgname=antlr27
+pkgver=2.7.7
+pkgrel=1
+pkgdesc="ANother Tool for Language Recognition"
+arch=('x86_64')
+url="http://www.antlr.org/"
+license=('BSD')
+depends=('dpkg')
+source=('http://ftp.funet.fi/pub/Linux/INSTALL/Ubuntu/archive/pool/main/a/antlr/libantlr-java_2.7.7+dfsg-6_all.deb'
+ 'http://ftp.funet.fi/pub/Linux/INSTALL/Ubuntu/archive/pool/main/a/antlr/antlr_2.7.7+dfsg-6_all.deb')
+sha1sums=('50f49bdfc9fa190715d13ca3f06a8ba9d6e34259'
+ '82f0033e967079c64351d5fb42e473daebb5889a')
+
+prepare() {
+ dpkg-deb -x libantlr-java_2.7.7+dfsg-6_all.deb ${srcdir}
+ dpkg-deb -x antlr_2.7.7+dfsg-6_all.deb ${srcdir}
+
+}
+
+package() {
+ cp -r ${srcdir}/usr ${pkgdir}
+}