summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--v0.1.0.tar.gzbin0 -> 19760 bytes
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f596fd26d03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-websearch
+ pkgdesc = Websearch plugin for searching the web with configurable engines.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-websearch
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = https://github.com/anyrun-org/plugin-websearch/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 006ee9aa3721fb84cc83b835fc7aa094d51b32a899c40995a189b8e61175bcb5
+
+pkgname = anyrun-plugin-websearch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e5cceff7078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+pkgname="anyrun-plugin-websearch"
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Websearch plugin for searching the web with configurable engines."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-websearch"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("https://github.com/anyrun-org/plugin-websearch/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('006ee9aa3721fb84cc83b835fc7aa094d51b32a899c40995a189b8e61175bcb5')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libwebsearch.so"
+}
diff --git a/v0.1.0.tar.gz b/v0.1.0.tar.gz
new file mode 100644
index 000000000000..65f14c9b7c0c
--- /dev/null
+++ b/v0.1.0.tar.gz
Binary files differ