summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33e7c08f090f..5ea03aa3e25c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = apertium-separable
pkgdesc = Module for reordering separable/discontiguous multiwords.
- pkgver = 0.3.6
+ pkgver = 0.6.1
pkgrel = 1
url = https://wiki.apertium.org/wiki/Apertium_separable
- arch = i686
- arch = x86_64
+ arch = any
license = GPL3
makedepends = pkgconf
makedepends = autoconf
makedepends = gcc
- depends = apertium>=3.4.2
+ makedepends = utf8cpp
+ depends = lttoolbox>=3.7.0
depends = zlib
- source = apertium-separable-0.3.6.tar.gz::https://github.com/apertium/apertium-separable/archive/refs/tags/v0.3.6.tar.gz
- sha256sums = 1da08205427e96ac7b812e66daa60a9f57fac2dbcec7a382fb074f74d268c9c4
+ source = apertium-separable-0.6.1.tar.gz::https://github.com/apertium/apertium-separable/archive/refs/tags/v0.6.1.tar.gz
+ sha256sums = 5a288f3aaf9f8a621e28423ee8bc81619305f24570279aa1cfdc75cfb2a40df7
pkgname = apertium-separable
-
diff --git a/PKGBUILD b/PKGBUILD
index 2b26b4a93226..c8cc9d496c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+# Maintainer: Marc Riera <marcriera@softcatala.org>
# Contributor: Kevin Brubeck Unhammer <unhammer@fsfe.org>
pkgname=apertium-separable
-pkgver=0.3.6
+pkgver=0.6.1
pkgrel=1
pkgdesc="Module for reordering separable/discontiguous multiwords."
url="https://wiki.apertium.org/wiki/Apertium_separable"
license=('GPL3')
-makedepends=('pkgconf' 'autoconf' 'gcc')
-depends=('apertium>=3.4.2' 'zlib')
-arch=('i686' 'x86_64')
+makedepends=('pkgconf' 'autoconf' 'gcc' 'utf8cpp')
+depends=('lttoolbox>=3.7.0' 'zlib')
+arch=('any')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/apertium/apertium-separable/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('1da08205427e96ac7b812e66daa60a9f57fac2dbcec7a382fb074f74d268c9c4')
+sha256sums=('5a288f3aaf9f8a621e28423ee8bc81619305f24570279aa1cfdc75cfb2a40df7')
build() {
+ export CXXFLAGS="$CXXFLAGS -I/usr/include/utf8cpp"
cd "$srcdir/${pkgname}-${pkgver}"
./autogen.sh --prefix=/usr
make