summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD23
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e53b027235c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = apigen
+ pkgdesc = Smart and Readable Documentation for your PHP project
+ pkgver = 4.1.2
+ pkgrel = 1
+ url = http://www.apigen.org/
+ arch = any
+ license = MIT
+ depends = php>=5.5
+ source = https://github.com/ApiGen/ApiGen/releases/download/v4.1.2/apigen.phar
+ source = LICENSE
+ sha256sums = 9563d5e1692bacb3974e2a8d287b8b89f8ca43cd7cd4ed89aefe30c6cdae7910
+ sha256sums = 2e5a9e806bc0b705f11f500ea57568ab1f4a3d5e63aa4b5bd3ecac3cf03e8fef
+
+pkgname = apigen
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f7c690d24792
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+The MIT License
+
+- Copyright (c) 2014 [Tomáš Votruba](http://tomasvotruba.cz)
+- Copyright (c) 2012 [Olivier Laviale](https://github.com/olvlvl)
+- Copyright (c) 2011 [Ondřej Nešpor](https://github.com/Andrewsville)
+- Copyright (c) 2011 [Jaroslav Hanslík](https://github.com/kukulich)
+- Copyright (c) 2010 [David Grudl](http://davidgrudl.com)
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..288cb0a16330
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Katoga <katoga.cz@hotmail.com>
+pkgname=apigen
+pkgver=4.1.2
+pkgrel=1
+pkgdesc="Smart and Readable Documentation for your PHP project"
+arch=('any')
+url="http://www.apigen.org/"
+license=('MIT')
+depends=('php>=5.5')
+source=(
+ "https://github.com/ApiGen/ApiGen/releases/download/v${pkgver}/apigen.phar"
+ 'LICENSE'
+)
+sha256sums=(
+ '9563d5e1692bacb3974e2a8d287b8b89f8ca43cd7cd4ed89aefe30c6cdae7910'
+ '2e5a9e806bc0b705f11f500ea57568ab1f4a3d5e63aa4b5bd3ecac3cf03e8fef'
+)
+
+package() {
+ install -Dm0644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ install -D apigen.phar ${pkgdir}/usr/bin/apigen
+}