summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c49316e4624b..dd07fd463336 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = appimageupdate-git
pkgdesc = Graphical front end to manage AppImage applications built using MauiKit
- pkgver = 2.0.0.alpha.1.20230526.r0.g496a69e
+ pkgver = 2.0.0.alpha.1.20230526.r1.gd89e6bf
pkgrel = 1
url = https://github.com/AppImageCommunity/AppImageUpdate
arch = x86_64
@@ -21,6 +21,7 @@ pkgbase = appimageupdate-git
depends = zsync2
provides = appimageupdate
conflicts = appimageupdate
+ options = staticlibs
source = git+https://github.com/AppImageCommunity/AppImageUpdate.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8d4fc5eb795a..78a277a9b588 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=appimageupdate-git
-pkgver=2.0.0.alpha.1.20230526.r0.g496a69e
+pkgver=2.0.0.alpha.1.20230526.r1.gd89e6bf
pkgrel=1
pkgdesc="Graphical front end to manage AppImage applications built using MauiKit"
arch=(x86_64)
@@ -11,12 +11,13 @@ depends=(glibc gcc-libs cpr gpgme libgcrypt zsync2)
makedepends=(git cmake argagg nlohmann-json libxpm cairo librsvg libappimage)
provides=(appimageupdate)
conflicts=(appimageupdate)
+options=(staticlibs)
source=("git+https://github.com/AppImageCommunity/AppImageUpdate.git")
sha256sums=('SKIP')
pkgver() {
cd AppImageUpdate
- git describe --long --tags --exclude latest | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --exclude latest --exclude continuous | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -40,4 +41,4 @@ package() {
cd AppImageUpdate/build
make DESTDIR="${pkgdir}/" install
install -D ../LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
-} \ No newline at end of file
+}