summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bde46b6d97bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = apron-git
+ pkgdesc = The Apron Numerical Abstract Domain Library
+ pkgver = r237.9ad5af8
+ pkgrel = 1
+ url = https://github.com/antoinemine/apron
+ arch = any
+ license = LGPL
+ depends = gmp
+ depends = mpfr
+ depends = ppl
+ provides = apron
+ conflicts = apron
+ source = git://github.com/antoinemine/apron.git
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = apron-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb7d238deee9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Deian Stefan
+# Partly based on https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=apron
+
+_pkgname=apron
+pkgname=apron-git
+pkgver=r237.9ad5af8
+pkgrel=1
+pkgdesc='The Apron Numerical Abstract Domain Library'
+arch=('any')
+url='https://github.com/antoinemine/apron'
+license=('LGPL')
+depends=('gmp' 'mpfr' 'ppl')
+makedepends=()
+provides=('apron')
+conflicts=('apron')
+source=('git://github.com/antoinemine/apron.git')
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $srcdir
+}
+
+build() {
+
+ cd "$srcdir/apron"
+
+ ./configure -no-cxx -no-java -no-ocamlfind -no-ocaml-plugins
+ make
+
+}
+
+package() {
+ cd "$srcdir/apron"
+ make APRON_PREFIX="$pkgdir"/usr install
+
+ # fix include/ permissions
+ find "$pkgdir"/usr/include -type d -exec chmod 755 '{}' ';'
+ find "$pkgdir"/usr/include -type f -exec chmod 644 '{}' ';'
+
+ # remove test binaries
+ rm "$pkgdir"/usr/bin/*test*
+}