summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52f504628878..3d8944f9419b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arc-kde
pkgdesc = Arc theme for KDE Plasma 5
pkgver = 20220908
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/PapirusDevelopmentTeam/arc-kde
arch = any
license = GPL3
@@ -12,9 +12,15 @@ pkgbase = arc-kde
sha256sums = bb4f547df20fc43fc19315cd0c96a447068abdc4095e7ae8b654a813e3422e93
pkgname = arc-kde
+ pkgdesc = Arc theme for Plasma 5 - Transitional package (install "plasma5-themes-arc")
+ depends = plasma5-themes-arc
+
+pkgname = plasma5-themes-arc
optdepends = arc-gtk-theme: Arc theme for GTK apps
optdepends = arc-icon-theme: Arc icon theme
optdepends = kvantum-theme-arc: Arc theme for Kvantum Qt style (recommended)
+ provides = arc-kde
+ replaces = arc-kde
pkgname = kvantum-theme-arc
pkgdesc = Arc theme for Kvantum
diff --git a/PKGBUILD b/PKGBUILD
index 56957f457987..6456e8dd5e3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Bruno Pagani <archange@archlinux.org>
pkgbase=arc-kde
-pkgname=(arc-kde kvantum-theme-arc)
+pkgname=(arc-kde plasma5-themes-arc kvantum-theme-arc)
pkgver=20220908
-pkgrel=2
+pkgrel=3
pkgdesc="Arc theme for KDE Plasma 5"
arch=(any)
url="https://github.com/PapirusDevelopmentTeam/${pkgbase}"
@@ -18,7 +18,16 @@ optdepends=(
)
package_arc-kde() {
+ pkgdesc='Arc theme for Plasma 5 - Transitional package (install "plasma5-themes-arc")'
+ depends=('plasma5-themes-arc')
+}
+
+# New package name using:
+# https://wiki.archlinux.org/title/KDE_package_guidelines#KF5_package_naming
+package_plasma5-themes-arc() {
optdepends+=('kvantum-theme-arc: Arc theme for Kvantum Qt style (recommended)')
+ provides=('arc-kde')
+ replaces=('arc-kde')
cd ${pkgbase}-${pkgver}
DESTDIR=$pkgdir IGNORE=Kvantum make install