summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
-rwxr-xr-xarcade-history-dat.install10
3 files changed, 29 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74d93e911482..7be7ecf3731b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = arcade-history-dat
- pkgdesc = Arcade History Database file to use for Emulators and Frontends with more than 36,000 entries!
- pkgver = 155
+ pkgdesc = arcade history database file for emulators and frontends with more than 61000 entries
+ pkgver = 186
pkgrel = 1
- url = http://www.arcade-history.com
+ url = https://www.arcade-history.com
+ install = arcade-history-dat.install
arch = any
license = custom
- optdepends = raine: for use in raine
- optdepends = qmc2: for use in qmc2
- source = http://www.arcade-history.com/dats/history155.7z
- sha256sums = 05e8bec9c2f3f1747e4f5bf772a68289191c1e4d3ec9938d8d806056d8a4aab6
+ optdepends = raine: for use in Raine
+ optdepends = qmc2: for use in QMC2
+ optdepends = sdlmame: for use in MAME
+ source = https://www.arcade-history.com/dats/history186.7z
+ sha256sums = 747c8934f416c5620babec5068acc23fb251c4915d270cee6d53436e5a009261
pkgname = arcade-history-dat
diff --git a/PKGBUILD b/PKGBUILD
index 877e2d5d62d4..ca4f5dc7a676 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=arcade-history-dat
-pkgver=155
+pkgver=186
pkgrel=1
-pkgdesc="Arcade History Database file to use for Emulators and Frontends with more than 36,000 entries!"
+pkgdesc="arcade history database file for emulators and frontends with more than 61000 entries"
arch=('any')
-url="http://www.arcade-history.com"
+url="https://www.arcade-history.com"
license=('custom')
-optdepends=('raine: for use in raine'
- 'qmc2: for use in qmc2')
+optdepends=('raine: for use in Raine'
+ 'qmc2: for use in QMC2'
+ 'sdlmame: for use in MAME')
source=("$url/dats/history$pkgver.7z")
-sha256sums=('05e8bec9c2f3f1747e4f5bf772a68289191c1e4d3ec9938d8d806056d8a4aab6')
+install=$pkgname.install
+sha256sums=('747c8934f416c5620babec5068acc23fb251c4915d270cee6d53436e5a009261')
package() {
install -Dm644 history.dat "$pkgdir"/usr/share/$pkgname/history.dat
@@ -20,8 +22,9 @@ package() {
ln -s /usr/share/$pkgname/history.dat "$pkgdir"/usr/share/raine/history.dat
# TODO: where to put it for other emulators/frontends?
+ # - MAME needs manual copy/symlink
# license
install -d "$pkgdir"/usr/share/licenses/$pkgname
- sed '/$end/,$d' history.dat > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ grep '^##' history.dat > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/arcade-history-dat.install b/arcade-history-dat.install
new file mode 100755
index 000000000000..ef62beb28032
--- /dev/null
+++ b/arcade-history-dat.install
@@ -0,0 +1,10 @@
+
+post_install() {
+ echo " => For use in MAME:"
+ echo " $ mkdir -p ~/.mame/dats"
+ echo " $ ln -sf /usr/share/arcade-history-dat/history.dat ~/.mame/dats/history.dat"
+}
+
+post_upgrade() {
+ post_install
+}