summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df95d5e2e487..66a0d90e4bfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arch-hs-git
pkgdesc = Distribute hackage packages to archlinux
- pkgver = r251.1203d2c
+ pkgver = 0.8.0.r12.g010cdd2
pkgrel = 1
url = https://github.com/berberman/arch-hs
arch = x86_64
@@ -9,7 +9,6 @@ pkgbase = arch-hs-git
makedepends = git
depends = ghc-libs
depends = haskell-aeson
- depends = haskell-req
depends = haskell-hackage-db
depends = haskell-megaparsec
depends = haskell-algebraic-graphs
@@ -21,7 +20,7 @@ pkgbase = arch-hs-git
depends = haskell-microlens
depends = haskell-microlens-th
depends = haskell-polysemy
- depends = haskell-optparse-applicative
+ depends = haskell-optparse-simple
depends = libalpm.so
depends = haskell-diff
depends = haskell-prettyprinter
diff --git a/PKGBUILD b/PKGBUILD
index f192863fb77b..355ebb53c729 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: berberman <hatsue@typed.icu>
pkgname=arch-hs-git
-pkgver=r251.1203d2c
+pkgver=0.8.0.r12.g010cdd2
pkgrel=1
pkgdesc="Distribute hackage packages to archlinux"
arch=('x86_64')
url="https://github.com/berberman/arch-hs"
license=('MIT')
-depends=('ghc-libs' 'haskell-aeson' 'haskell-req' 'haskell-hackage-db' 'haskell-megaparsec'
+depends=('ghc-libs' 'haskell-aeson' 'haskell-hackage-db' 'haskell-megaparsec'
'haskell-algebraic-graphs' 'haskell-conduit' 'haskell-tar-conduit' 'haskell-conduit-extra'
'haskell-split' 'haskell-neat-interpolation' 'haskell-microlens' 'haskell-microlens-th'
- 'haskell-polysemy' 'haskell-optparse-applicative' 'libalpm.so' 'haskell-diff'
+ 'haskell-polysemy' 'haskell-optparse-simple' 'libalpm.so' 'haskell-diff'
'haskell-prettyprinter' 'haskell-prettyprinter-ansi-terminal' 'haskell-arch-web'
)
makedepends=('ghc' 'git')
@@ -22,7 +22,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
_gen_comp(){
@@ -54,7 +54,7 @@ build() {
_gen_comp
_gen_comp "-diff"
- _gen_comp "-submit"
+ _gen_comp "-sync"
}
package() {
@@ -67,5 +67,5 @@ package() {
_install_comp
_install_comp "-diff"
- _install_comp "-submit"
+ _install_comp "-sync"
}