summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c63ae554e942
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = architects-daughter-font
+ pkgdesc = a font incorporating the graphic, squared look of architectural writing and the natural feel of daily handwriting
+ pkgver = 1.003
+ pkgrel = 1
+ url = https://fonts.google.com/specimen/Architects+Daughter
+ arch = any
+ license = OFL
+ source = architects-daughter-1.003.zip::https://fonts.google.com/download?family=Architects+Daughter
+ sha256sums = 61d4fdc773a3c6a6e2f15af909521df7ec58642ed3d59b5393278578bd56114b
+
+pkgname = ttf-architects-daughter
+ provides = architects-daughter-font
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43f0477abee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_name=architects-daughter
+pkgbase=$_name-font
+pkgname=(ttf-$_name)
+pkgver=1.003
+pkgrel=1
+pkgdesc='a font incorporating the graphic, squared look of architectural writing and the natural feel of daily handwriting'
+arch=(any)
+url="https://fonts.google.com/specimen/Architects+Daughter"
+license=(OFL)
+source=("$_name-$pkgver.zip::https://fonts.google.com/download?family=Architects+Daughter")
+sha256sums=('61d4fdc773a3c6a6e2f15af909521df7ec58642ed3d59b5393278578bd56114b')
+
+package_ttf-architects-daughter() {
+ provides=("$pkgbase")
+ install -Dm0644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
+}