summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ee44d9694ba..943641303ff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arcus-beta-git
pkgdesc = Communication library between internal components for Ultimaker software
- pkgver = 4.0
+ pkgver = r367.cfb4921
pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = x86_64
@@ -15,7 +15,6 @@ pkgbase = arcus-beta-git
provides = libarcus
conflicts = arcus
conflicts = libarcus
- conflicts = arcus-beta
source = git+https://github.com/Ultimaker/libArcus#branch=4.0
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1abe91373f06..12a7c9dd05f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=arcus-beta-git
-pkgver=4.0
+pkgver=r367.cfb4921
pkgrel=1
pkgdesc="Communication library between internal components for Ultimaker software"
arch=('x86_64')
@@ -13,10 +13,15 @@ license=('LGPL3')
depends=('python' 'protobuf' 'python-sip')
makedepends=('cmake' 'git' 'sip')
provides=('arcus' 'libarcus')
-conflicts=('arcus' 'libarcus' 'arcus-beta')
-source=("git+${url}#branch=${pkgver}")
+conflicts=('arcus' 'libarcus')
+source=("git+${url}#branch=4.0")
md5sums=('SKIP')
+pkgver(){
+ cd libArcus
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd libArcus
mkdir -p build