summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--arkclientv2.desktop16
-rw-r--r--arkclientv2.svg97
4 files changed, 183 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e4bfa9af15e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ark-desktop-v2
+ pkgdesc = Multi Platform Ark Lite Client for core V2 devnet
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/ArkEcosystem/ark-desktop
+ arch = x86_64
+ license = MIT
+ depends = gtk2
+ depends = alsa-lib
+ depends = nss
+ depends = libxtst
+ depends = gconf
+ depends = libxss
+ source = https://github.com/ArkEcosystem/ark-desktop/releases/download/1.6.1/ArkClient-V2-Linux-1.6.1.tar.xz
+ source = https://raw.githubusercontent.com/ArkEcosystem/ark-desktop/1.6.1/LICENSE
+ source = arkclientv2.desktop
+ source = arkclientv2.svg
+ sha256sums = d3ea9e286fdf28759d302d91e21b42c23ccdc2d7bb6633b1f3c785421d04ec65
+ sha256sums = c051061bad8e5d6783a5d631cd3efa47cc13883b97e5651be185e30fa93dcfe6
+ sha256sums = b167d2faf16aa10d9bdeaafd2a397b6022a10a06ede0f76f1525142451f708d0
+ sha256sums = 8ca038afc96c8d1604711fd22f7fc3f75bb7004eac1090e109af843554c9a31e
+
+pkgname = ark-desktop-v2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..524905048a24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Florens Pauwels <mail@florens.be>
+# Contributor: LĂșcio Rubens <luciorubeens@gmail.com>
+
+_npmnamev1=ArkClient
+_npmname=${_npmnamev1}-V2
+_appnamev1=arkclient
+_appname=${_appnamev1}v2
+_pkgnamev1=ark-desktop
+pkgname=${_pkgnamev1}-v2
+
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Multi Platform Ark Lite Client for core V2 devnet"
+arch=(x86_64)
+url="https://github.com/ArkEcosystem/ark-desktop"
+license=(MIT)
+depends=('gtk2' 'alsa-lib' 'nss' 'libxtst' 'gconf' 'libxss')
+
+source=(
+ "https://github.com/ArkEcosystem/${_pkgnamev1}/releases/download/${pkgver}/${_npmname}-Linux-${pkgver}.tar.xz"
+ "https://raw.githubusercontent.com/ArkEcosystem/${_pkgnamev1}/${pkgver}/LICENSE"
+ "${_appname}.desktop"
+ "${_appname}.svg"
+)
+
+sha256sums=(
+ "d3ea9e286fdf28759d302d91e21b42c23ccdc2d7bb6633b1f3c785421d04ec65"
+ "c051061bad8e5d6783a5d631cd3efa47cc13883b97e5651be185e30fa93dcfe6"
+ "b167d2faf16aa10d9bdeaafd2a397b6022a10a06ede0f76f1525142451f708d0"
+ "8ca038afc96c8d1604711fd22f7fc3f75bb7004eac1090e109af843554c9a31e"
+)
+
+package() {
+ cd "${srcdir}/${_npmnamev1}-${pkgver}"
+
+ install -d ${pkgdir}/{opt/${pkgname},usr/bin}
+ cp -a * ${pkgdir}/opt/${pkgname}
+ rm ${pkgdir}/opt/${pkgname}/LICENSE*
+ ln -s /opt/${pkgname}/${_appnamev1} ${pkgdir}/usr/bin/${_appname}
+
+ install -Dm644 "${srcdir}/${_appname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"
+ install -Dm644 "${srcdir}/${_appname}.svg" "${pkgdir}/usr/share/pixmaps/${_appname}.svg"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+ chmod -R ugo+rX "${pkgdir}/opt"
+} \ No newline at end of file
diff --git a/arkclientv2.desktop b/arkclientv2.desktop
new file mode 100644
index 000000000000..5284f37c462f
--- /dev/null
+++ b/arkclientv2.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Version=1.0
+Name=Ark Desktop V2
+Comment=Ark Wallet Lite Client
+TryExec=/usr/bin/arkclientv2
+Exec=/usr/bin/arkclientv2
+Terminal=false
+Type=Application
+Icon=arkclientv2
+Categories=Office;Finance;
+MimeType=x-scheme-handler/ark;
+Actions=Explorer;
+
+[Desktop Action Explorer]
+Exec=xdg-open https://explorer.ark.io
+Name=Ark Blockchain Explorer \ No newline at end of file
diff --git a/arkclientv2.svg b/arkclientv2.svg
new file mode 100644
index 000000000000..69498873216b
--- /dev/null
+++ b/arkclientv2.svg
@@ -0,0 +1,97 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="512"
+ height="512"
+ viewBox="0 0 135.46666 135.46666"
+ version="1.1"
+ id="svg0"
+ inkscape:version="0.92.2 5c3e80d, 2017-08-06"
+ sodipodi:docname="arkclient.svg">
+ <defs
+ id="defs0" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="0.70710678"
+ inkscape:cx="-29.456852"
+ inkscape:cy="381.20528"
+ inkscape:document-units="mm"
+ inkscape:current-layer="layer0"
+ showgrid="true"
+ units="px"
+ showguides="true"
+ inkscape:guide-bbox="true"
+ inkscape:window-width="1657"
+ inkscape:window-height="957"
+ inkscape:window-x="228"
+ inkscape:window-y="45"
+ inkscape:window-maximized="0">
+ <inkscape:grid
+ type="xygrid"
+ id="grid4517" />
+ <sodipodi:guide
+ position="67.73333,0"
+ orientation="1,0"
+ id="guide4522"
+ inkscape:locked="false"
+ inkscape:label=""
+ inkscape:color="rgb(0,0,255)" />
+ <sodipodi:guide
+ position="0,67.73333"
+ orientation="0,1"
+ id="guide4524"
+ inkscape:locked="false"
+ inkscape:label=""
+ inkscape:color="rgb(0,0,255)" />
+ <sodipodi:guide
+ position="108.47916,39.687498"
+ orientation="0,1"
+ id="guide4532"
+ inkscape:locked="false" />
+ </sodipodi:namedview>
+ <metadata
+ id="metadata0">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Ebene 0"
+ inkscape:groupmode="layer"
+ id="layer0">
+ <g
+ id="arkclient">
+ <circle
+ r="67.73333"
+ cy="67.73333"
+ id="path4519"
+ style="fill:#ff233f;fill-opacity:1;stroke-width:2.73795772"
+ cx="67.73333" />
+ <path
+ id="rect4515"
+ d="M 67.733332,34.395856 26.19375,100.54169 67.733332,58.208356 109.27292,100.54169 Z m 10e-7,33.33747 -6.879166,7.40834 H 74.6125 Z m -11.641667,12.17086 -6.879166,7.14375 h 37.041665 l -6.879166,-7.14375 z"
+ style="opacity:1;fill:#ffffff;fill-opacity:1;stroke:none;stroke-width:0.13229166;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:0.2"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="cccccccccccccc" />
+ </g>
+ </g>
+</svg>