summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4d31f15a3b6..f7d4882964e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-gcc-stage1
pkgdesc = The GNU Compiler Collection. Stage 1 for toolchain building
- pkgver = 13.2.0
- pkgrel = 2
+ pkgver = 14.1.0
+ pkgrel = 1
url = https://gcc.gnu.org
arch = x86_64
license = GPL
@@ -16,13 +16,13 @@ pkgbase = arm-linux-gnueabihf-gcc-stage1
options = !emptydirs
options = !distcc
options = !strip
- source = https://sourceware.org/pub/gcc/releases/gcc-13.2.0/gcc-13.2.0.tar.xz
- source = https://sourceware.org/pub/gcc/releases/gcc-13.2.0/gcc-13.2.0.tar.xz.sig
+ source = https://sourceware.org/pub/gcc/releases/gcc-14.1.0/gcc-14.1.0.tar.xz
+ source = https://sourceware.org/pub/gcc/releases/gcc-14.1.0/gcc-14.1.0.tar.xz.sig
validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
validpgpkeys = D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62
- sha256sums = e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da
+ sha256sums = e283c654987afe3de9d8080bc0bd79534b5ca0d681a73a11ff2b5d3767426840
sha256sums = SKIP
pkgname = arm-linux-gnueabihf-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index a804848c50bf..9803432b478d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@
_target=arm-linux-gnueabihf
pkgname=${_target}-gcc-stage1
-pkgver=13.2.0
+pkgver=14.1.0
_majorver=${pkgver%%.*}
-pkgrel=2
+pkgrel=1
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building"
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -23,15 +23,13 @@ validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
-sha256sums=('e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da'
+sha256sums=('e283c654987afe3de9d8080bc0bd79534b5ca0d681a73a11ff2b5d3767426840'
'SKIP')
prepare() {
cd gcc-${pkgver/+/-}
- # do not run fixincludes
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
- # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
mkdir -p "${srcdir}"/gcc-build