summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c2e60133453
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = arm-linux-gnueabihf-gcc49-linaro-bin
+ pkgdesc = The GNU Compiler Collection- cross compiler for ARMv7 EABI hard float target. (Linaro)
+ pkgver = 4.9.4
+ pkgrel = 1
+ url = https://releases.linaro.org/components/toolchain/binaries
+ arch = x86_64
+ groups = arm-linux-gnueabihf-toolchain-linaro-bin
+ license = GPL
+ license = LGPL
+ provides = arm-linux-gnueabihf-gcc
+ conflicts = arm-linux-gnueabihf-gcc
+ replaces = arm-linux-gnueabihf-gcc
+ options = !emptydirs
+ options = !strip
+ options = staticlibs
+ source = https://releases.linaro.org/components/toolchain/binaries/4.9-2017.01/arm-linux-gnueabihf/gcc-linaro-4.9.4-2017.01-x86_64_arm-linux-gnueabihf.tar.xz
+ sha256sums = 22914118fd963f953824b58107015c6953b5bbdccbdcf25ad9fd9a2f9f11ac07
+
+pkgname = arm-linux-gnueabihf-gcc49-linaro-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d3858ed5237
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Collide <three-dim-sky@foxmail.com>
+# https://github.com/TD-Sky/PKGBUILDs
+
+_target=arm-linux-gnueabihf
+_pkgdate=2017.01
+_pkgver=4.9
+
+pkgname=${_target}-gcc49-linaro-bin
+pkgver=4.9.4
+pkgrel=1
+pkgdesc="The GNU Compiler Collection- cross compiler for ARMv7 EABI hard float target. (Linaro)"
+arch=('x86_64')
+url="https://releases.linaro.org/components/toolchain/binaries"
+license=('GPL' 'LGPL')
+groups=(${_target}-toolchain-linaro-bin)
+provides=("${_target}-gcc")
+conflicts=("${_target}-gcc")
+replaces=("${_target}-gcc")
+options=(!emptydirs !strip staticlibs)
+source=(${url}/${_pkgver}-${_pkgdate}/${_target}/gcc-linaro-${pkgver}-${_pkgdate}-${arch}_${_target}.tar.xz)
+sha256sums=('22914118fd963f953824b58107015c6953b5bbdccbdcf25ad9fd9a2f9f11ac07')
+
+package() {
+ mkdir ${pkgdir}/usr
+ cp -a ${srcdir}/gcc-linaro-${pkgver}-${_pkgdate}-${arch}_${_target}/* -t ${pkgdir}/usr
+
+ mkdir -p ${pkgdir}/usr/arm-linux-gnueabihf/usr/bin
+ mv ${pkgdir}/usr/bin/gdbserver -t ${pkgdir}/usr/arm-linux-gnueabihf/usr/bin
+
+ rm -f ${pkgdir}/usr/*-manifest.txt
+ rm -f ${pkgdir}/usr/bin/runtest
+ rm -f ${pkgdir}/usr/lib/lib*
+ rm -rf ${pkgdir}/usr/include
+ rm -rf ${pkgdir}/usr/share/{dejagnu,doc,gcc-*,gdb,info,locale}
+ rm -rf ${pkgdir}/usr/share/man/{man1/runtest.1,man5,man7}
+}