summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dfb5835bee6..a0336a6bb5af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = arsdk3
arch = x86_64
license = custom
makedepends = repo
- makedepends = python
makedepends = python2
options = !emptydirs
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 709d818013f3..b165d167421e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,21 @@ license=('custom')
source=('git+https://github.com/Parrot-Developers/arsdk_manifests')
options=(!emptydirs staticlibs)
md5sums=('SKIP')
-makedepends=('repo' 'python' 'python2')
+makedepends=('repo' 'python2')
prepare() {
cd "$srcdir"
- repo init -u arsdk_manifests -b 4b50e865427e6f2f2f19be1d4c55ab87a03b804a \
+ yes|repo init -u arsdk_manifests -b 4b50e865427e6f2f2f19be1d4c55ab87a03b804a \
--no-clone-bundle --depth=1
repo sync
}
build() {
+ # Make sure to use python 2 with scripts: they fail with v3.6+
+ mkdir "$srcdir/bin" || true
+ ln -s /usr/bin/python2 "$srcdir/bin/python"
+ export PATH="$srcdir/bin":$PATH
+
"$srcdir"/build.sh -p arsdk-native -t build-sdk -j
}