summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--arx-libertatis-1.1.2-cmake-3.5.patch33
3 files changed, 47 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92c5bfcf5163..1b845b35f19e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri Mar 25 16:17:23 UTC 2016
pkgbase = arxlibertatis
pkgdesc = Cross-platform port of Arx Fatalis, a first-person fantasy RPG (executables only)
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://arx-libertatis.org/
install = arxlibertatis.install
arch = i686
@@ -15,14 +17,16 @@ pkgbase = arxlibertatis
optdepends = arxfatalis-data-gog: game data from GOG.com installer
optdepends = arxfatalis-data-copy: game data from existing win32 installation
optdepends = arxfatalis-data-demo: game data from official freeware demo
- optdepends = qt: enable built-in crash handler (Qt5 version; recompile needed)
+ optdepends = qt5-base: enable built-in crash handler (Qt5 version; recompile needed)
optdepends = qt4: enable built-in crash handler (Qt4 version; recompile needed)
optdepends = gdb: generate detailed crash reports
provides = arx
conflicts = arx-git
replaces = arx-libertatis
source = http://downloads.sourceforge.net/arx/arx-libertatis-1.1.2.tar.xz
+ source = arx-libertatis-1.1.2-cmake-3.5.patch
md5sums = 543dfdaaaaf7c337227c1b6a3087589a
+ md5sums = 9f7fb2bc6878ba97d1b83781721490bf
pkgname = arxlibertatis
diff --git a/PKGBUILD b/PKGBUILD
index a918e0ef503c..8c1820788ce2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=arxlibertatis
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Cross-platform port of Arx Fatalis, a first-person fantasy RPG (executables only)'
url='http://arx-libertatis.org/'
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ depends=('sdl' 'openal' 'glew')
optdepends=('arxfatalis-data-gog: game data from GOG.com installer'
'arxfatalis-data-copy: game data from existing win32 installation'
'arxfatalis-data-demo: game data from official freeware demo'
- 'qt: enable built-in crash handler (Qt5 version; recompile needed)'
+ 'qt5-base: enable built-in crash handler (Qt5 version; recompile needed)'
'qt4: enable built-in crash handler (Qt4 version; recompile needed)'
'gdb: generate detailed crash reports')
makedepends=('boost' 'cmake')
@@ -22,12 +22,16 @@ conflicts=('arx-git')
install='arxlibertatis.install'
_archivefolder=arx-libertatis-$pkgver
-source=("http://downloads.sourceforge.net/arx/$_archivefolder.tar.xz")
-md5sums=('543dfdaaaaf7c337227c1b6a3087589a')
+source=("http://downloads.sourceforge.net/arx/$_archivefolder.tar.xz"
+ "arx-libertatis-1.1.2-cmake-3.5.patch")
+md5sums=('543dfdaaaaf7c337227c1b6a3087589a'
+ '9f7fb2bc6878ba97d1b83781721490bf')
build() {
cd $_archivefolder
+ patch < "$srcdir"/arx-libertatis-1.1.2-cmake-3.5.patch
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBEXECDIR=lib/arx \
-DCMAKE_BUILD_TYPE=Release \
diff --git a/arx-libertatis-1.1.2-cmake-3.5.patch b/arx-libertatis-1.1.2-cmake-3.5.patch
new file mode 100644
index 000000000000..c39624e2ef5f
--- /dev/null
+++ b/arx-libertatis-1.1.2-cmake-3.5.patch
@@ -0,0 +1,33 @@
+From c4262bc600dc01d3ddbacc7811132b29ea46ad3b Mon Sep 17 00:00:00 2001
+From: Daniel Scharrer <daniel@constexpr.org>
+Date: Thu, 24 Mar 2016 22:47:44 +0100
+Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
+
+This makes the build system more robust against stray variables
+coming from included CMake scripts provided by the system.
+
+Fixes build with CMake 3.5.
+
+This has been fixed in master with commit 60e43c.
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 93f1ee3..8347544 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,6 +13,11 @@ else()
+ cmake_minimum_required(VERSION 2.8)
+ endif()
+
++if(POLICY CMP0054)
++ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
++ cmake_policy(SET CMP0054 NEW)
++endif()
++
+
+ # Define configuration options
+
+--
+2.7.4