summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rwxr-xr-xasciidocfx14
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a0dafb96f6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = asciidocfx
+ pkgdesc = Asciidoc Editor and Toolchain written with JavaFX 8
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://asciidocfx.com/
+ arch = any
+ license = Apache
+ makedepends = maven>=3.3.9
+ makedepends = java-environment-openjdk=8
+ depends = java-environment=8
+ depends = java-openjfx>=8.u76
+ source = https://github.com/asciidocfx/AsciidocFX/archive/v1.5.0.tar.gz
+ source = asciidocfx
+ sha256sums = 8e31e7f8ca9fb40045273557089dd3580097bc99fea8904b6d471d12865f8c0e
+ sha256sums = a7b4491ff8d379519c5085b9779c613695c2be941f3473422d69cefbdb9d3d95
+
+pkgname = asciidocfx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0beb4a17b3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Corey Richardson <corey@octayn.net>
+pkgname=asciidocfx
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Asciidoc Editor and Toolchain written with JavaFX 8"
+arch=('any')
+url="http://asciidocfx.com/"
+license=('Apache')
+depends=('java-environment=8' 'java-openjfx>=8.u76')
+makedepends=('maven>=3.3.9' 'java-environment-openjdk=8')
+source=("https://github.com/asciidocfx/AsciidocFX/archive/v$pkgver.tar.gz"
+ 'asciidocfx')
+noextract=()
+sha256sums=(
+'8e31e7f8ca9fb40045273557089dd3580097bc99fea8904b6d471d12865f8c0e'
+'a7b4491ff8d379519c5085b9779c613695c2be941f3473422d69cefbdb9d3d95'
+)
+
+build() {
+ cd "AsciidocFX-$pkgver"
+
+ # "install" seemingly means "build and ready for installation"
+ mvn clean install
+}
+
+package() {
+ cd "AsciidocFX-$pkgver"
+
+ install -dm755 "$pkgdir/usr/share/java/asciidocfx"
+ install -dm755 "$pkgdir/usr/bin"
+ mv -t "$pkgdir/usr/share/java/asciidocfx" target/appassembler/{conf,lib}
+ install -m775 ../asciidocfx "$pkgdir/usr/bin/asciidocfx"
+}
diff --git a/asciidocfx b/asciidocfx
new file mode 100755
index 000000000000..c95c02e21424
--- /dev/null
+++ b/asciidocfx
@@ -0,0 +1,14 @@
+#!/bin/sh
+BASEDIR=/usr/share/java/asciidocfx
+for name in $BASEDIR/lib/*.jar; do
+ CP=$CP:$name
+done
+
+exec /usr/bin/java -cp $CP -Duser.language=en -Duser.country=US -XX:+UseG1GC \
+ -Dapp.name="asciidocfx" \
+ -Dapp.pid="$$" \
+ -Dapp.repo="$BASEDIR/lib" \
+ -Dapp.home="$BASEDIR" \
+ -Dbasedir="$BASEDIR" \
+ com.kodcu.boot.AppStarter \
+ "$@" \ No newline at end of file