summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-linux-4.20.patch56
-rw-r--r--PKGBUILD11
3 files changed, 70 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35411f0e74ad..14efb48103cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asix-dkms
pkgdesc = A kernel module for ASIX AX88760 AX88772 AX88772A AX88772B AX88772C AX88178 USB 2.0 network adapters
pkgver = 4.23.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.asix.com.tw/
arch = i686
arch = x86_64
@@ -10,10 +10,12 @@ pkgbase = asix-dkms
provides = asix-dkms
provides = asix-module
conflicts = asix-module
- source = https://www.asix.com.tw/FrootAttach/driver/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.23.0_Source.tar.gz
+ source = https://www.asix.com.tw/FrootAttach/driver/AX88772C_772B_772A_760_772_178_Linux_Driver_v4.23.0_Source.tar.bz2
source = asix-dkms.conf
+ source = 0001-linux-4.20.patch
sha512sums = 7c43eed69e948f2d921b758c2dab1236540832c7ce48b7308b6e3fa5ee1e4f4bc9f190e1497ea85d7a953959bd86f00461ae81c0bbd710959c7dafba6c4c2688
sha512sums = ded1bed08f61ce207e394fc4f49345f0ea50639f53fb797907402b3503feecc485ba85fb799f2b3bc9c22cd4a250509c5eb99d4b36d42228a9475a9e7d67b293
+ sha512sums = e9e7025e8157d6950200a45a07d35de99c1342a60f02fa1701753e589cfa1964de86c136e8ce26f51d284cd716f75fe9953b1ee09381e9f1599aa89c8e61db8f
pkgname = asix-dkms
diff --git a/0001-linux-4.20.patch b/0001-linux-4.20.patch
new file mode 100644
index 000000000000..d764d857a536
--- /dev/null
+++ b/0001-linux-4.20.patch
@@ -0,0 +1,56 @@
+*** a/asix.c 2019-01-16 12:10:22.829797420 +0100
+--- b/asix.c 2019-01-16 12:11:59.521251711 +0100
+***************
+*** 1034,1041 ****
+--- 1034,1043 ----
+ .set_wol = ax8817x_set_wol,
+ .get_eeprom_len = ax8817x_get_eeprom_len,
+ .get_eeprom = ax8817x_get_eeprom,
++ #if LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0)
+ .get_settings = ax8817x_get_settings,
+ .set_settings = ax8817x_set_settings,
++ #endif /* LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0) */
+ };
+
+ static int ax8817x_ioctl(struct net_device *net, struct ifreq *rq, int cmd)
+***************
+*** 1327,1334 ****
+--- 1329,1338 ----
+ .set_wol = ax8817x_set_wol,
+ .get_eeprom_len = ax8817x_get_eeprom_len,
+ .get_eeprom = ax8817x_get_eeprom,
++ #if LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0)
+ .get_settings = ax8817x_get_settings,
+ .set_settings = ax8817x_set_settings,
++ #endif /* LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0) */
+ };
+
+ static int ax88772_bind(struct usbnet *dev, struct usb_interface *intf)
+***************
+*** 1934,1941 ****
+--- 1938,1947 ----
+ .set_wol = ax8817x_set_wol,
+ .get_eeprom_len = ax8817x_get_eeprom_len,
+ .get_eeprom = ax8817x_get_eeprom,
++ #if LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0)
+ .get_settings = ax8817x_get_settings,
+ .set_settings = ax8817x_set_settings,
++ #endif /* LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0) */
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 3, 0)
+ .set_tx_csum = ax88772b_set_tx_csum,
+ .get_tx_csum = ax88772b_get_tx_csum,
+*** a/axusbnet.c 2019-01-16 12:10:27.516534560 +0100
+--- b/axusbnet.c 2019-01-16 12:12:34.741781672 +0100
+***************
+*** 896,903 ****
+--- 896,905 ----
+
+ /* drivers may override default ethtool_ops in their bind() routine */
+ static struct ethtool_ops axusbnet_ethtool_ops = {
++ #if LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0)
+ .get_settings = axusbnet_get_settings,
+ .set_settings = axusbnet_set_settings,
++ #endif /* LINUX_VERSION_CODE < KERNEL_VERSION(4,20,0) */
+ .get_link = axusbnet_get_link,
+ .nway_reset = axusbnet_nway_reset,
+ .get_drvinfo = axusbnet_get_drvinfo,
diff --git a/PKGBUILD b/PKGBUILD
index f6d2d95ef327..d0d0742ef6da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=asix-dkms
pkgver=4.23.0
-pkgrel=1
+pkgrel=2
pkgdesc="A kernel module for ASIX AX88760 AX88772 AX88772A AX88772B AX88772C AX88178 USB 2.0 network adapters"
arch=('i686' 'x86_64')
@@ -22,12 +22,21 @@ _filename="AX88772C_772B_772A_760_772_178_Linux_Driver_v${pkgver}_Source"
source=(
"https://www.asix.com.tw/FrootAttach/driver/${_filename}.tar.bz2"
'asix-dkms.conf'
+ '0001-linux-4.20.patch'
)
sha512sums=(
'7c43eed69e948f2d921b758c2dab1236540832c7ce48b7308b6e3fa5ee1e4f4bc9f190e1497ea85d7a953959bd86f00461ae81c0bbd710959c7dafba6c4c2688'
'ded1bed08f61ce207e394fc4f49345f0ea50639f53fb797907402b3503feecc485ba85fb799f2b3bc9c22cd4a250509c5eb99d4b36d42228a9475a9e7d67b293'
+ 'e9e7025e8157d6950200a45a07d35de99c1342a60f02fa1701753e589cfa1964de86c136e8ce26f51d284cd716f75fe9953b1ee09381e9f1599aa89c8e61db8f'
)
+prepare() {
+ cd "${srcdir}/${_filename}"
+
+ # Linux kernel internals changed since Linux 4.20.
+ patch -p1 < "${srcdir}/0001-linux-4.20.patch"
+}
+
package() {
# We are in the source directory ./src/
# Please note the source of the driver are in a subfolder: