summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD26
3 files changed, 30 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3154a4615915..9459e2911585 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = atkinson-hyperlegible-fonts
- pkgdesc = typeface with greater legibility and readability for low vision readers
- pkgver = 1
+ pkgdesc = Font that is easier to read across the entire visual-ability spectrum. Focuses on letterform distinction.
+ pkgver = 1.02
pkgrel = 1
url = https://www.brailleinstitute.org/freefont
arch = any
- license = none
+ license = custom
source = https://www.brailleinstitute.org/wp-content/uploads/atkinson-hyperlegible-font/Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514.zip
+ source = LICENSE
sha256sums = 9e1a65d53ddadc8253791e958a07bf5aba210ef6155ea9c91b2b4c46bbce53e3
+ sha256sums = e16e151abad1cd5f7dfaddf0b3309ba98c93daa8a7dce9d53505c4b0e5c6a1b6
pkgname = atkinson-hyperlegible-fonts
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..61b8915adc74
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+© 2020 Braille Institute of America, Inc., a 501(c)(3) Charitable Organization.
+
+https://www.BrailleInstitute.org/
+
+Braille Institute of America, Inc. provides Atkinson Hyperlegible for use,
+without derivatives or alteration, to the public free of charge for all
+non-commercial and commercial work. No attribution required.
diff --git a/PKGBUILD b/PKGBUILD
index 6736013eee2e..6ea0700405fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,27 @@
# Maintainer: Stick <stick@stma.is>
+# Maintainer: MountainX
pkgname=atkinson-hyperlegible-fonts
-pkgver=1
+pkgver=1.02
pkgrel=1
-pkgdesc='typeface with greater legibility and readability for low vision readers'
+pkgdesc='Font that is easier to read across the entire visual-ability spectrum. Focuses on letterform distinction.'
url='https://www.brailleinstitute.org/freefont'
arch=('any')
-license=('none')
-source=('https://www.brailleinstitute.org/wp-content/uploads/atkinson-hyperlegible-font/Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514.zip')
-sha256sums=('9e1a65d53ddadc8253791e958a07bf5aba210ef6155ea9c91b2b4c46bbce53e3')
+license=('custom')
+source=('https://www.brailleinstitute.org/wp-content/uploads/atkinson-hyperlegible-font/Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514.zip'
+ 'LICENSE')
+sha256sums=('9e1a65d53ddadc8253791e958a07bf5aba210ef6155ea9c91b2b4c46bbce53e3'
+ 'e16e151abad1cd5f7dfaddf0b3309ba98c93daa8a7dce9d53505c4b0e5c6a1b6')
package() {
- mkdir -p "$pkgdir"/usr/share/fonts/{TTF,OTF}
- install -D -m0644 "$srcdir"/Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514/"Print Fonts"/*.otf "$pkgdir"/usr/share/fonts/OTF/
- install -D -m0644 "$srcdir"/Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514/"Web Fonts"/TTF/*.ttf "$pkgdir"/usr/share/fonts/TTF/
+ mkdir -p "$pkgdir"/usr/share/{fonts/{TTF,OTF},licenses/"$pkgname"}
+ install -D -m0644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/
+
+ for _dir in 'Print Fonts' 'Web Fonts/TTF'; do
+ cd "$srcdir/Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514/$_dir" || exit
+ for _font in *.?tf; do
+ _EXT="${_font##*.}"
+ install -m 644 "$_font" "$pkgdir"/usr/share/fonts/"${_EXT^^}"/"${_font/-${pkgver/./}/}"
+ done
+ done
}